accelerator pump problem

Discussion in 'Engine, Fuel and Exhaust' started by nascar7613, Mar 12, 2010.

  1. nascar7613

    nascar7613 Active Member

    218
    28
    3
    93 1200 sportster accelerator pump not working. Took off carb everything is clean. Funny thing is when you hold the float bowl in the upright position, the way it would be when installed on the bike, I press the accelerator pump rod 1 time and it does not return to its original position, it sticks. But if I turn the float bowl sideways, 45 degrees from the way it would sit on the bike, the pump works and returns to its original position. If I shake the bowl, I can hear something banging around in there. Is there a check ball or something that might be dislodged and blocking the passage when I turn the carb upright then moves out of the way when I turn it sideways?
     
  2. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,277
    133
    156
    Well if you shake the float bowl around and hear something bangining in there it may be the float
    inside the float bowl sits a float it purpous is to regulate the depth of fuel in the bowl
    it does this by means of a needle valve
    as the depth of fuel in the bowl increases then the float rises and closes the flow of fuel into the bowl as the fuel is used then the float drops opening the valve and allowing fuel into the bowl
    by shaking the carb about you may have damaged the float or needle valve ?
    the accelerator pump is a spring loaded diaphram located to the side of the float bowl
    as you snap the throttle open a rod pushes down on the diaphram squirting fuel out of the accelerator jet the diaphram is then reset by the spring this is a fairly delicate instrument that does not respond well to being shaken
    you will need a service manual and a carb rebuild kit strip clean and reassemble with new parts from the kit

    Brian
     
  3. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    100
    Check this out:

    CARBURETOR - 1993 Harley Davidson FXDL


    #210, 270, 264, etc. are your accelerator pump. Pull the three screws out (#168) and check the diaphram to see if it is cut or broken. Also, clean out any "goo".

    #360 and 300 are your float and float needle discussed above.

    TQ
     
    Last edited: Mar 12, 2010
  4. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113

    On my sporty, sitting for a time WITH THIS GOOD GAS WE HAVE TODAY.... When i took my carb apart I sprayed carb cleaner and soaked the little part areas ... The cleaner REMOVED the gukk that made the accelerator pump SLUGGISH...

    signed....BUBBIE
     
  5. nascar7613

    nascar7613 Active Member

    218
    28
    3
    When I shake the bowl it is off the carb, I'm not shaking the whole carb. It's just the bowl with nothing attached with something rattling inside like a check ball.
     
  6. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    If you have the BOWL and shake it. THE SPRING and diaphragm unit might be make the noise. SPRING BAD?

    TRY THIS,,, PUT the plunger rod into the spot on the BOWL and press it DOWN all the way, taking out ALL the PLAY with the pumper in fully complete down position..... the plunger should make that area tight.... THEN shake it.... Is the noise gone?

    DO you have the accelerator pump gutted out and it makes this noise???

    Even tho it doesn't show it in the break-down of carb, I thought there were TUBEs cast into the bowl bottom housing that had a small ball to seal off???? JUST memory.....

    Maybe I'll PM chopper to have a read here..

    signed....BUBBIE
     
  7. nascar7613

    nascar7613 Active Member

    218
    28
    3
    I found the problem! There is a small hole in the float bowl right above the accelerator pump housing that was clogged. Cleared it out and it works perfect. Thank you for the input.