ABS light flashing

Discussion in 'Touring Models' started by dlfidler, Jun 14, 2012.

  1. dlfidler

    dlfidler Member

    56
    16
    0
    Good morning I ride a 2008 Ultra, getting ready for a 5 day ride, leaving shortly. I checked the bike over, started the bike, the ABS light is flashing & will not cancel. Any suggestions. Thanks
     
  2. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    42
    Take it for a ride,if the light stops flashing after you reach 4-5 miles per hour you are OK.
    If not it is warning you that the brake pads are worn and need replacing.
     
  3. Mavagrand

    Mavagrand Senior Member

    1,250
    48
    12
    Seriously?? I had no idea the system would do that.
     
  4. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    42
    The subject came up a while ago when I was thinking about buying a bike with ABS and that is what a Harley mechanic friend of mine told me.I have no reason to doubt him.He is one of the best techs I have ever known.
     
  5. Breeze3at

    Breeze3at Well-Known Member

    4,643
    83
    123
    I had never heard of this (I don't have abs) before Steve posted his reply. I just googled "Harley abs light flashing" and got many returns that agree, it's self diagnostics that can't reset until the wheels move. I learned something with the first post I read today on the best HD site on the net. :bigsmiley12:
     
    HDDon likes this.
  6. jimharvey1

    jimharvey1 Junior Member

    467
    28
    7
    Mine has flashed after startup until I roll the bike since new. It's the ABS system arming and syncing. I didn't know that if it continued to flash it indicated worn brake pads though. Just that the ABS system detected a fault and that ABS was disabled. Good to know! Thanks.
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Like modern cages with ABS this is called an ABS roll off test, the system is self checking itself
     
  8. JOHNNYREDPEN

    JOHNNYREDPEN Member

    32
    18
    2
    My ABS light came on and stayed on. Guy who services my bike connected it to his PC and ran diagnostic. Open circuit code. Changed front wheel bearing which has ABS sensor in it...no joy. Changed rear bearing again with sensor....no joy. Rode bike a few days later. Bike ran self check and flashing ABS light went off when I set off (as it should).Did 30 miles light stayed off. Got home it came on again! It has done this for a while now. I was going to change the front ABS sensor and lead but the intermittent problem suggests a loose or dry joint. I believe the lead goes up behind the headlight (2009RK)......anyone had similar or offer a solution?
     
  9. mlrc10

    mlrc10 Active Member

    107
    26
    0
    So did the new pads fix the problem? I recently took a Head and Eyes class taught by a state trooper and rode cones for almost 4 hours. Hard. The only time I wasn't riding is when I lost rear brakes 3 different times (hot). After they cooled down the pedal would come right back. By the end, it felt like the rear brake was dragging a little. Next next time or two I rode it, the ABS light flashed and it still felt like it was dragging a little and the pedal got soft fast. I pulled the caliper this evening and it took 2 pretty large screwdrivers to get the pistons moving. The pads are about 7/8 worn. The fluid in the reservior looks pretty good, as does the rotor. The blood suckers ran me out of the shop just before dark, so I'll get it put back together tomorrow evening and see what happens. I'm fairly sure the pads aren't the only problem. The fluid may be used up or the caliper is going away. Any suggestions or ideas are appreciated. Thanks

    BTW it's a 2010 Ultra Classic with a little over 50,000 miles.
     
  10. Spike

    Spike Member

    12
    13
    1
    I have a 2010 Ultra classic. I had the same symptoms, intermittent flashing of ABS. I had disconnected the lead from the front left ABS sensor while installing new tire under the fairing and somehow managed to get it tangled in the clutch cable. When I would turn the fairing, sometimes it would cause the lead to pull loose from the terminal it plugs into and the ABS light would start blinking. Long story short, I had to replace the lead (about $70) because the wires got pulled from the terminal. Once I replaced the lead and insured it didn't get caught in the clutch cable when the handle bars were turned the ABS light stopped flashing. Took about three stabs at getting the lead attached so it didn't get snagged by clutch cable. Be sure and cinch the lead down well with a wire tie to keep it from moving around...