A question on Cruise Controll

Discussion in 'General Harley Davidson Topic' started by Fourdogs, Aug 4, 2009.

  1. Fourdogs

    Fourdogs Junior Member

    805
    28
    3
    Ok .. heres whats happening... Sometimes it will set just fine. Going along and kicks off maybe after 20 minutes are so. Then other times won't set at all...and other times it will set for like a few second....So..where do i start..any help would be greatly appreciated . Like i guess something is loose..so where do i look?
     
  2. IndyRoadKing

    IndyRoadKing Member

    11
    11
    0
    My first guess would be either your front or rear brake light switch is making contact some how. Check to see if your brake lights come on with just slight movement of the front lever or rear pedal.

    Next would be the "roll off" switch. On my 06 it is located on the throttle cable where it goes along the frame. You will see to wires that you can unplug to disable the switch.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Throttle cable lash is the biggest problem with this. Adjust the slack in the cable and if that doesn't do it the brake activation mentioned above could be the problem.

    You'll find the activation switch in the cable just under the front of the tank.
     
  4. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    43
  5. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Pretty neat and subtle procedure, glad to see that Steve07 is nostalgic...wasn't it the cruise control you put on your bike that brought you to the forum way back when? :D

    Nice to see it go full circle...:cheers
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
  7. Fourdogs

    Fourdogs Junior Member

    805
    28
    3
    Thanks gentlemen...will get a chance to give it a shot this weekend..and will let ya fella's know if that took care of it...
     
  8. Fourdogs

    Fourdogs Junior Member

    805
    28
    3
    WoW..you guys ROCK..did the procedure:D in the manual as y'all suggested ..and Bing Boom Bang...all is well thanks everyone for your help.
     
  9. glider

    glider Veteran Member

    25,464
    108
    44
    No trip to the dealer now :D

    Glad it worked out.