99' dyna won`t start

Discussion in 'General Harley Davidson Topic' started by greensteele, Mar 31, 2014.

  1. greensteele

    greensteele Member

    10
    0
    0
    HEY GUYS, just want to say hi, and maybe some one can help me with a problem? I was out riding today, bike was running fine. Stopped to get gas, and when I started the bike up it gave a large pop sound and now it will not start. It turns over fine, all switches are on, has any one had this problem before? Thinking it might be the timing chain, getting my hands dirty tomorrow....:D
     
  2. stray dog

    stray dog Junior Member

    443
    26
    0
    Welcome to the forum!

    Was the pop sound like a backfire or more metallic?

    Let us know what you find!
     
  3. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,328
    133
    175
    Has the bike got a carb or is it injected

    Brian
     
  4. greensteele

    greensteele Member

    10
    0
    0
    Hey stray dog, Thanks for getting back to me! it was a back fire, like a pop it seemed to come from the left side but not sure, it was very quick...
     
  5. greensteele

    greensteele Member

    10
    0
    0
    Hey fin 676, it is a carb
     
  6. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,349
    73
    141
    Power to everything? Lights on etc.?
     
  7. greensteele

    greensteele Member

    10
    0
    0
    hey stray dog, the back fire had a electrical smoky smell, if that helps....Thanks

    power on everything, engine turns over...

    seat is off all wires seem to be in good shape, coil seems good, plugs have usual wear, new battery....
     
    Last edited by a moderator: Mar 31, 2014
  8. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,349
    73
    141
    Basics first. Fuel and fire. Check to see if in the the throat of the carb that you get a spray of fuel when twisting the throttle. Next, pull the plugs and check for fire.
     
  9. BUBBIE

    BUBBIE Well-Known Member

    4,971
    83
    121
    Is the Vacuum line to the tank off-on Valve and into the Carb in place?
    (blown off by back-fire)

    IF not? Problem found,,,,,No fuel is getting to the carb. :s

    signed....BUBBIE
     
  10. Jack Klarich

    Jack Klarich Guest