98 road king...running errattic

Discussion in 'Engine, Fuel and Exhaust' started by yarddog, Nov 28, 2009.

  1. yarddog

    yarddog Member

    6
    0
    0
    I have a 98 road king with mag morelli injection...owned it since 99 and has always run good til recently...runs fine at start up...drive down the road about 3 or 4 miles and it acts almost like its running out of gas or "choking out"...when you try to roll into the throttle the engine just dies...let up and it returns to idle...other symptoms include idle will go up very high, black smoke from the exhaust, engine will be hard starting if shut off while its doing this...check engine light is not coming on (and yes it does work)...have checked various electrical connections, cleaned air bleed holes, removed and checked crank sensor tip, replaced fuel filter, replaced plugs...after the bike sits and idles for about 5 mins or so all returns to normal and it runs ok...not sure where to go from here...any help would be greatly appreciated
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Have you checked the injector harness near the injector plug? There was a problem with the copper breaking inside the insulation on the front injector. Also have you done a fuel pressure test and also eliminated fuel contamination and a bad hose inside the fuel tank.
     
  3. yarddog

    yarddog Member

    6
    0
    0
    have pretty much ruled out contaminated fuel...put fresh in...checked hoses in the tank while replacing the filter...all looked good...will check the injector harness and do a fuel pressure check...do you know where to hook a pressure guage in?...I'm guessing the plugged port on the fuel pressure hose fitting at the outlet port of the tank
     
  4. glider

    glider Veteran Member

    25,464
    108
    44