'92 FXR Horn Location

Discussion in 'Dyna Models' started by Conolon Kid, Aug 25, 2010.

  1. Conolon Kid

    Conolon Kid Member

    55
    0
    0
    Seriously? I mean...seriously? Why didn't they mount it somewhere easier to get to? Like inside the fuel tank.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Because then the horn would go... Beep Beep Boom! :D
     
  3. Conolon Kid

    Conolon Kid Member

    55
    0
    0
    I went straight from shovels to a TwinCam. Never owned or even rode an Evo till I bouht this '92 last month. The first time I hit the horn button and nothing happened, I looked around and thought "Huh, no horn." Wouldn't be the first bike without one. I was tellin' a buddy I needed a horn and he said "Wait a minute, I think it's in a weird place on these" and sure enough, we found it. Now I gotta find the time to tear half the bike apart to replace it. Looks like I gotta take the battery out. I'm hoping the mounting bolt will be staring me in the face, otherwise I'm just gonna haffta stay with my "custom Horn".

    horn.jpg
     
  4. maine-e-axe

    maine-e-axe Junior Member

    732
    28
    1
    Spray some WD-40 in the horn and let it soak, sometimes they'll start working again.
     
  5. Conolon Kid

    Conolon Kid Member

    55
    0
    0
    Right into the bell?
     
  6. maine-e-axe

    maine-e-axe Junior Member

    732
    28
    1
    Ya right in the bell. maybe 2 or 3 times.
     
  7. Conolon Kid

    Conolon Kid Member

    55
    0
    0
    If that works, you're gonna be my new best friend.
     
  8. ProF

    ProF Junior Member

    508
    28
    1
    I have an '86.....
    I read your comment and almost fell out of my chair!:D
     
  9. Breeze3at

    Breeze3at Well-Known Member

    4,641
    83
    122
    Is it mounted above the transmission, between the frame tubes? My '92 Dyna is mounted there. The horn was barely audible at idle. I was able to reach the wire connector fairly easily, and put a jumper wire in it. I bought a $10 6 volt (yep, 6v) chrome mcy. horn and mounted it between my front down tubes.
    That 6v horn is pretty loud, and has lasted 15 yrs.
    I've used the WD 40 in the horn, on cars and bikes with pretty good results.