92 Electra Glide Classic

Discussion in 'Touring Models' started by snapper5, Sep 11, 2011.

  1. snapper5

    snapper5 Member

    6
    0
    0
    This bike has sat for about 2 years. Ran fine when it was parked. The enricher has to be on before it will run without backfiring through the carb. Carb has been cleaned. Any ideas?
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Harley Davidson Community Replace intake seals and rebuild the carb, now would be a good time to change plugs wires and clean the tappet screen
     
  3. snapper5

    snapper5 Member

    6
    0
    0
    All of that has already been done. Intake isn't leaking.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Try some fresh gas with a bit of Seafoam?:s
     
  5. snapper5

    snapper5 Member

    6
    0
    0
    Did that too. :)
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Float level OK and not hanging up? This would explain the choke problem, look from the left side of bike between the cylinders, you will see a screw on the float bowl, this will drain the float bowl see how much and how dirty the gas is Check the vacum petcock and remove the gas cap and see how it runs
     
    Last edited: Sep 11, 2011
  7. snapper5

    snapper5 Member

    6
    0
    0
    Already did all that. Carb has been cleaned, twice, float adjusted, new gas, replaced the upper diaphram and cleaned all the jets. At a total loss as to what is wrong.
     
  8. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    How is the compression? Is the VOE switch working? Sounds like a carb problem be it a hole in the diaphragm or not getting enough fuel
     
  9. snapper5

    snapper5 Member

    6
    0
    0
    Compression in 127 lbs per cylinder. Diaphram is new and the VOE switch is by-passed.
     
  10. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    So , you are saying the carb has been cleaned, new gas, but has the carb been completely gone through with new parts, the reason for this question is even with a good gleaning bad gas will cause a lot of problems internally in small bleed holes and all rubber sealing parts