883C Sportster won't start

Discussion in 'Sportster Models' started by kirbear21, Sep 4, 2011.

  1. kirbear21

    kirbear21 New Member

    1
    0
    0
    A couple months back when i was riding i noticed my Speedometer and Odometer were not working and my turn signals would not automatically shut off after making a turn (not sure if the two are related). Now my bike won't start at all! The headlights work and the battery is brand new. Is there anything i can do to trouble shoot so i can at least get the bike to the shop? Thanks for any help!

    Also, when i do try to start it it just makes a clicking sound....
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Check the connections at the starter, they will work loose and corrode, try jumping the battery lug and green wire at the starter, Does it start? Load test the battery, clean and tight connections, Negative off first and last on. Just because a battery is new does not always mean it is good. Check to see the starter bolts are tight and the starter is grounded:s
     
  3. The Tourist

    The Tourist Banned

    216
    0
    1
    Hey, Cap'n Jack, your mood says you're in pain. Everything okay?

    My first impression when I read the OP was that there might be some gremlin at work since so many electrical systems are acting flakey. Do you have access to equipment, or a typical seven year old boy who know computers, to check for error codes?

    Also check for bundle chafing. Sometimes a slight rub mark touching the frame can cause insipient shorts.
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    You did not say if you resolved those issues or are they still Not working. Does the bike have any Factory or non Factory FOB security?
     
  5. TripleJ

    TripleJ Senior Member

    1,081
    48
    8
    After you get the starting issue resolved, you will need to check for diagnostic codes to see if any exist.

    http://www.hdtalking.com/archive/index.php/t-5991.html

    As for the speedo/odometer and turn signal issues, I think you may find a problem with the Vehicle Speed Sensor.

    Welcome to the forum!
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    From what you describe the VSS on the transmission sounds like the problem.

    Harley Davidson Community