88 flhtc electrical problem

Discussion in 'Touring Models' started by vnvbear, Jun 14, 2009.

  1. vnvbear

    vnvbear Member

    8
    11
    0
    i have a 1988 flhtc, runs 14 volts with all electrics off, turn on headlights still running 13 volts but lot of times misses and starts running plugs too rich, changed regulator, stator shows fine and checked grounds, can anyone help? ride free
     
  2. Fossil

    Fossil Active Member

    335
    28
    1
    I have a 1988 FLTC/FLHS and I doubt the charging system is your problem. There are others on here who can help you much better than I can. If it was my bike I would think how long ago the spark plug wires were replaced and start looking for loose gounds from the battery forward. Give a little more information on when the bike starts cutting out. Does it do this idling or on the road or what? Fossil
     
  3. Fossil

    Fossil Active Member

    335
    28
    1
    Oops, didn't mean to put my answer in bold print. Excuse me. Fossil
     
  4. vnvbear

    vnvbear Member

    8
    11
    0
    thanks for reply fossil, i believe it is a ground problem in firing system, system shows charging 14.02 volts with lights off and 13.85 with them and fog lamps on at 2000 rpms, grounds seem good , about ready to change to points, ride safe
     
  5. hntwrobin

    hntwrobin Active Member

    236
    26
    0
    Check the wires going to the coil. If they are loose or possibly damaged it could be your problem.
     
  6. dangerdan

    dangerdan Junior Member

    922
    26
    0
    Never assume grounds seem good.
    A voltage drop of .17 v is nothing to worry about.

    I agree with fossil.
    Look for a carb problem
    Check plugs/wires/ignition coil and timing.
     
  7. 2006FXDCI

    2006FXDCI Active Member

    182
    28
    1
    thanks yall, replaced plug wires with 8.8 accell, new screaming eagle coil, s&s super e carb is fine, going back at it tommorrow. thanks

    :cheers well i've tried everything i can, i guess i'm going to order a 38 amp 3 phase stator upgrade kit and see what happens

    I didn't know you could go directly through them, I was under the impression you had to go through one of their dealers. Do you know if they make a complete engine for my 2006 dyna?

    have you had any experience with the zippers muscle 107 complete motor, it seems to have some impressive numbers as far as tq. and hp.

    okay, tried this today, had motor running, turned on all lights and started missing and cutting out, hooked 20 amp charger to battery and all problems went away, has a new deka 300 amp battery which is same as harley, turn charger off and misses instantly, if charging system shouldn't battery be going down or do i need a bigger charging system, this is getting expensive real quick. what are your thoughts fossil?
     
    Last edited by a moderator: Jun 28, 2009