87 heratage sofail not getting fire

Discussion in 'Electrical' started by brandon251980, Aug 3, 2014.

  1. brandon251980

    brandon251980 Member

    5
    0
    0
    ive got 87 softail that wont start its not getting fire I replaced coil and still not getting fire I do have power to coil don't have any idea it has a Mallory ignition in it could that be the problem not sure how to test it thanks for any help
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Need more info on exact ignition trigger
    Check the wires coming out of the cone are they pinched, burned up?
    Open up the cone cover what do you see?
    Explain power to coil? Both sides?
    During cranking?
     
  3. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    I am not sure what kind of connector is used for the wiring to the coil but, some thing else to check for when a loss of power is suspected is to make sure all the wiring connectors are firmly seated in there respective connector bodies.
     
  4. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Have you checked all the fuses 1st?
    And the battery cables for proper tightness.
     
  5. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    The old stand-by cure for electrical problems on older bikes is to load test the battery, and if that checks out, remove the battery cables, wire brush both sides of the mating surfaces and reattach. Do this for both end of both cables disconnecting the negative cable first and reattaching it last.

    If it is not that, then we have to dig in.

    Cheers,

    TQ
     
    Last edited: Aug 6, 2014
  6. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,316
    73
    130
    Without knowing more about it. I'll throw out a guess of Crank Position Sensor.
     
  7. tourbox

    tourbox Senior Member

    1,311
    68
    54
    Are you talking about Mallory Uni-Lite. There should be 3 wires coming from the module.
    The Red goes to the battery side of the coil(+ side). The Green, trigger wire, goes to the other side of the coil(- side). The Brown goes to a good ground, i.e. battery neg. side or frame ground. If it were to be hooked up wrong then it is Toast. I believe you can test by placing your VOM red lead to the battery side of the coil. Turn Key on, but don't start the bike. With a credit or business card place it between the 2 LED lights on the module. The voltage should drop from 12Vdc to 2 Vdc or less. If it is more than 2 Vdc then the unit is bad.
    tourbox
     
  8. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    If this is a 87 model it has no crank sensor. All the ignition is in the nose cone unless it still has a control module, that said if the OP were to crank the engine to TDC, key on loosen the stand off screws on the sensor, ground #1 plug to the head and rotate the sensor you would see a spark IF the pick up were working

    Technical Support Help Desk

    Get help with your questions by signing up today. Our service department is the definitive resource for installation, configuration,troubleshooting and general customer service. If you have a question about your Mr. Gasket, Hays, Lakewood, ACCEL, ACCEL Motorcycle, Mallory, or QuickTime product, create an account for our help desk.

    For purchase related inquiries please contact customer service.
    Click here to visit our help desk.
    Reach us by phone:216.658.6413

    Hours:
    8:30 AM – 5:00 PM EST M-F

    Mailing address:
    Prestolite Performance
    10601 Memphis Ave. # 12
    Cleveland, Ohio 44144
     
    Last edited by a moderator: Aug 6, 2014
  9. brandon251980

    brandon251980 Member

    5
    0
    0
    yes its was hooked up right band battery was good
    coil has 12 volts on both sides
     
  10. tourbox

    tourbox Senior Member

    1,311
    68
    54
    Did you try to block the light and see if the 12Vdc dropped on one side of the coil ? If it didn't then your module is bad. Certain numbers on the module itself you can get at Auto Zone, they may have to order it though.
    tourbox