79 shovel clutch

Discussion in 'Transmission' started by solo, Apr 29, 2008.

  1. solo

    solo Member

    10
    11
    0
    I bought this bike in 1981 and the clutch has never been real smooth i have replaced disc over the years trying to help but not any better.I had to pull tranny to replace seals and main shaft so I went ahead and replaced everything in clutch except the clutch shell.
    1.new 5 stud hub with long rollers
    2.new steel plates
    3.new disc,alto red eagle
    4.new aluminum pressure plate
    5.new springs
    6.new cable
    7.new adjusting screw
    8. new push rod.
    adjusted clutc and cable by the manuel but when I put it in gear it kills motor.The adjusting screw moves outward about 1/8" or so when lever is pulled but clutch still holding.The 5 stud hub came with a thin plastic piece with hole pattern of studs in hub where does it go there were no instruction with hub when i got it.
     
  2. Fisher

    Fisher Account Removed

    341
    0
    1
    The plastic peice with ten holes (clutch hub liner) in it goes on the clutch hub before the basket and hub are assembled.There's several small cone shaped springs to secure it usually but some are floating and use no springs to hold them.If that's not installed correctly it'll cause problems.So we're talking about the same thing does it look like it'll fit on the largest part of this hub at the bottom?

    [​IMG]
     
  3. solo

    solo Member

    10
    11
    0
    Thanks for replies.I guess all the stars and planets lined up last night about 11:00.I put everything back together and this clutch has not been this sweet in years.Put it in 1st gear, no dragging at all.I rode until about 1:30 this morning no problems.I did find a few things that were wrong the last time I had it apart.
    1.The new springs I got were not all the same,two were alot heavier than the other 8 and the two were next to each other not letting the pressure plate release evenly.I put the old springs back in.
    2. the new pushrod was short by 1/8"
    3.the new clutch hub was not seated all the way back on main shaft,dressed the key a little and it went on fine.

    Fisher I thought I figured out where the plastic liner went but was not sure until your post,Thanks.

    I'm at work now but when I get the guys lined up for the day I'm gone riding.
     
  4. Fisher

    Fisher Account Removed

    341
    0
    1
    Cool.Glad you got 'er sorted out.