2014 ultra limited cooling fans problem

Discussion in 'Touring Models' started by quiticokid, Aug 13, 2016.

  1. quiticokid

    quiticokid Member

    78
    18
    1
    Just got back from a 6,250 mile awesome trip to Sturgis, British Columbia, and a lot of other awesome places. Toward the end of the ride the cooling fans for the engine heads started kicking out the fuses. These fans almost always only run for about 15 seconds after a ride. Anyway I took it to a Harley Dealership on the way home. The mechanic trouble shooted it for 1 1/2 hours and could not find the problem and said that it must be in the wiring somewhere they said that As long as I was traveling and air was going thru the radiators the bike would be OK. After getting home I left it at a local Dealership to see what they can do. The Service Boss said that another guy had the problem and they could not fix it. I left the bike there and they are going to try to fix it on mine. Anyone else have the problem and know how to repair.
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    I would bet that coolant fan sensor is out of range and reading cold all the time. If within the parameters that sensor is designed it may not set a check engine light. I doubt that wiring is cause. I am surprised that a factory trained Harley dealer would state to customer as long as you keep moving which is not a constant while riding it you will be ok and that second stated that they could not repair another customers bike with same complaint. I would be very cautious of getting a correct repair and may try another dealer.. Maybe third strike will be a charm and 3rd dealer will get you corrected.
    Just for the joke of it has coolant been checked to be sure that it is full for a coolant sensor needs submerge to operate properly.
     
  3. quiticokid

    quiticokid Member

    78
    18
    1
    Checking the coolant was the first thing I checked, Also they told me that if my engine would start to overheat.the engine would go into the LIMP MODE and would only go a maximum of thirty miles per hour.
     
  4. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    This is what's frustrating about the whole Harley thing with dealers at times. They tell you they can not repair bike but try to calm your concerns while traveling by telling you if bike overheats then it will go into limp mode. What happens after it starts to melt down and now you are stranded in no mans land and then told once towed to dealer that there is no warranty cause you were aware fans were inop and rode anyways. Now the fight begins. It seems to be getting worse at dealers instead of better. Especially with all the sophistication of Harleys now a days. All these systems on bikes now a days have a prescribed dio flow chart or method to dio and repair. I remember when complex systems came out in cars and independents could not repair and car had to go to dealer. With these Harleys you go to dealer and they can not repair bike so now where do you turn.
    Not very confidence inspiring if you ask me.:(:confused:o_O
     
  5. joel

    joel Junior Member

    523
    38
    48
    Is there 1 fuse for both fans, or do each have 1 fuse?
    Should be able to test the amp draw from each fan, or may even listen to see if 1 fan seems faster than the other.
    Electric motors can be tricky, sometimes drag and pop a fuse, sometimes spin to fast and pop a fuse.
     
  6. quiticokid

    quiticokid Member

    78
    18
    1
    Real good idea, Joel, I dropped the bike off at the dealer on friday and they are going to try to figure it out,if they have no luck I will bounce the things off them that you and dbmg suggested. Thank you both for your ideas
     
  7. Harttoo

    Harttoo Senior Member

    1,113
    68
    80
    Hope They figure it out.It's a wierd symptom.Interested in hearing how They fix it.
     
    quiticokid likes this.
  8. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,601
    103
    296
    I assume this is a warranty issue? I certainly would not be satisfied with the response "we can't figure it out"
    If the dealer gives you a song and dance i'd try a new dealer along with a direct call to the MOCO.
    We can't figure it out is simply not acceptable from so called trained professionals.
     
    bobalu, quiticokid and dbmg like this.
  9. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Searching the web I found a couple forums that talked about pump failures that cause fuses to blow.
     
    quiticokid likes this.
  10. quiticokid

    quiticokid Member

    78
    18
    1
    When I get the bike back I will let you all know what is going on, Thanks again for your input