2011 Sportster Starter won't engage flywheel

Discussion in 'Electrical' started by SnakebitN, Apr 13, 2015.

  1. SnakebitN

    SnakebitN New Member

    That's the first problem the real problem started 2 years ago went to go ridding battery was dead.It was in warranty dealer came and got it got it back they said needed a new battery,not even 6 months old.They also told me to clean the fuses & relays every now and then.I was Pissed ! So I did and rode away and for awhile it started dying on me while ridding in traffic and sitting at lights.I had these same problems with a 2009 Sportster,a wreck fixed that problem.Dumby here bought another Sportster they said it was new and improved.Right it has a little over 5K miles on it been in storage for 2-3 years cause it won't start or run.All it will do is the lights will come on rt.turn signal comes on not blinking just on.You hit the start button the starter zings,so I got a new starter,new battery all new fuses,relays( starter).Still the same the starter zings and will not engage the flywheel,thinking a bad spot on the flywheel I rocked the bike in gear same thing zings.The fuel pump comes on also what's next the motor can't be locked up no miles it turns over by hand. :51:
  2. tourbox

    tourbox Senior Member

    Are we talking 2011 XL? Seeing as how you stated you put a new starter on I would start there. Pull your primary cover off, after draining the fluid. Hit you starter button momentarily and see if the starter gear goes forward to engage the ring gear on the clutch. If it does and all you get is the zinging then I would say the starter clutch sub assy. is bad. It could be the ring gear on clutch hub has gone bad, but not likely.