2010UC Radio comes on at Start up??

Discussion in 'Communications And Radio' started by kdultra, Aug 16, 2011.

  1. kdultra

    kdultra Member

    18
    0
    0
    I have a unique issue with my 2010UC.
    Every single time I start it the radio comes on! No CD in the radio and it was not on before I shut down the bike.

    HEre is the rub, I took it to the dealer to get them to look into it before the factory warranty expires next month. They told me that it is normal and they all do that. WHAT????

    2 of my fellow riders have a 2010 & 2011 Street glide and theit radios only come on when they actually push the button.. As it should be...

    Has anyone else experienced this or know of the issue?
    What has their dealer told them?

    Thanks....Ken
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    I have an 05RG and if the radio is on when I shut the bike off it comes on when I start it up. If the radio is off on shut down it's off on start up.
     
  3. TripleJ

    TripleJ Senior Member

    1,081
    48
    8
    But Don, they all do that :lolrolling
     
  4. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    So it would seem.:newsmile04::newsmile04:
     
  5. pfschmidt

    pfschmidt Member

    28
    11
    0
    yes my 2010 classic does that too. But it is not all the time. I just did a long extended road trip (6200 miles) and it stopped doing it ?? So what is the answer? Maybe radio stops coming on after a few miles are on it call it breakin

    Ride safe
    Pete