2010 low HP and Torque on Dyno

Discussion in 'Touring Models' started by Moxie, Oct 3, 2009.

  1. Moxie

    Moxie Member

    8
    0
    0
    I did pipes, air breather and supertuner on my 2010 UC Limited - today was Dyno day and they stopped after getting baseline data - they could not get the torque and HP where it should be... it was way low - said they saw the same thing on another 2010 and that it was a misalligned oil pump. They are contacting HD to get authorization to repair - the good news... while they are in there I'm going to upgrade my cams (free labor)
    Anyone heard of this problem yet?
     
  2. Moxie

    Moxie Member

    8
    0
    0
    It was less than what an 88 will put out - I don't remember the number but I do remember that sad statement by the tech when he was taking it off the machine...
     
  3. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    WHAT, oilpump PRESSURE must be low.... I have never heard of engine torque low b-cause of mis aligned oil pump....

    OILPUMP pressure must of been what they told you was LOW....

    CORRECT ME IF U WILL .....ANYBODY PLEASE!!!!

    signed....BUBBIE
     
  4. mstngjoe

    mstngjoe Member

    95
    16
    0
    I've heard of the oil pump being misaligned resulting in a wet sump condition. That would drag the top end numbers down.
     
  5. Moxie

    Moxie Member

    8
    0
    0
    thanks, Ill find out more this week and post the story
     
  6. spartacus55

    spartacus55 Active Member

    113
    26
    0
    so hobbit your saying if hd service did the dyno your actual numbers should be 15-20% higher because their measuring at the crank not the wheel so when they told me my numbers were 84 hp and 104 tq my actual hp could be as high as 100 and my tq in the 120 range?