2010 Dyna FXDC given a little pop

Discussion in 'Dyna Models' started by Heck52, Sep 30, 2009.

  1. Heck52

    Heck52 Member

    80
    18
    1
    Hey folks, I'm fairly new here. I just reached 1,000 miles on my 2010 FXDC and am taking it to the dealer for its checkup. One thing i have noticed is when I start it it gives a one pop in the exhaust and fires right up and runs great. Its done this since new. I had a 2008 XL1200 before so i'm not up on the 96 cubes. Any input before i get to the dealer next week.
     
  2. TexasFXD

    TexasFXD Member

    9
    1
    0
    It's normal, my 2009 does exactly the same.
     
  3. Heck52

    Heck52 Member

    80
    18
    1
    Thanks, When I scheduled my 1,000 checkup I mentioned it to the dealer. He said there are some software updates but wasn't sure if they had anything to do with the pop. Like I said I hit the starter it goes pop on the first fire and zroom, runs like a champ. Anyway thanks again
     
  4. Heck52

    Heck52 Member

    80
    18
    1
    Thanks Hobbit, At least i'm not the only one. I guess you could call it a bang in the exhaust pipe. When you put your hand over the rear cylinder pipe you can feel it. Mine does it pretty much everytime, hot or cold. My brother who has a 09 streetbob does it also, but not all the time. Anyway thanks

    Just to update. The dealer says all newer 96ers do this. Its the first fire and gets it over the hump
     
    Last edited by a moderator: Oct 15, 2009
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    It's the ONLY time when the dealer says "they all do it" he would not be lying!

    Don't sweat it. Totally normal.


    Hoop!
     
    Last edited: Oct 24, 2009