2010 Dyna Brake light question

Discussion in 'General Harley Davidson Topic' started by IrishRob56, May 17, 2014.

  1. IrishRob56

    IrishRob56 New Member

    3
    0
    0
    A little background.....I have a 2010 FXDC with the brake, run, turn module installed to run everything on the rear turn signal lights. I bottomed out the bike and rubbed and shorted out two of the wires going to the right tail light...this burnt out the brake, run, turn module as well as the TSM. I've replaced the brake, run, turn module and am awaiting the TSM. I've been told by several on the forum that the brake lights run on a separate circuit than the TSM. I still have no brake lights or running lights at the rear. With the brakes not applied I have 8.5 VDC at the brake light wire...Red/Yellow. When the brakes are applied...front or rear the voltage drops to 0 VDC. That seems backwards to me. Is there a stop light relay that is maybe burnt out? I can't find anything on the wiring diagram showing this. Any help will be greatly appreciated.
     
  2. Harttoo

    Harttoo Senior Member

    1,107
    68
    80
    Blue should have 12v for running lights and red,yellow should have 12v when brake switch front or rear is made.You may have a wiring problem should not zero when switch is made. 8.5V is not right,You still have wiring issue or improper ground.
     
  3. tourbox

    tourbox Senior Member

    1,310
    68
    54
    I would take off the module and see if it works correctly. I agree with Harttoo on his post. But not sure what voltage is where with the module in place.
    tourbox