2008 ultra stumble and hesitation

Discussion in 'Touring Models' started by monsterilg, Nov 1, 2010.

  1. monsterilg

    monsterilg New Member

    4
    0
    0
    my 08 ran good for 10k miles then started to stumble. had sert and true duels install 2k miles. runs good when cold most of the time dose it a lot after 50 to 75 miles on hwy then when i get in town it will start. on hwy once and a while after gear change.also after it sits while in store for gas or short brake been back to shop had new crank sensor and dino #2 now stumbles about same computer show no codes dino 2 shows 1hp less 2 fpt more than one. read a lot about ve's or is it vt's charts don't have actess or know how to this stuff how about any suggestion.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    A few things can cause that type of problem but the very first thing I would check is vacuum leaks in the throttle body area. Intake seals or any O rings for map sensor/IAC etc. From what you said it sure sounds like an air intake leak of some kind. Perform the WD40 or propane test to check & find that leak. I would NOT change any mapping values or electrical parts before I was Sure I had no air intake leaks.
     
  3. monsterilg

    monsterilg New Member

    4
    0
    0
    thanks for ideas will try when i get it back from shop
     
  4. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
  5. monsterilg

    monsterilg New Member

    4
    0
    0
    no work done befor this started all work was done at 2k miles sert and true dules ran good for 10k miles oil change every 2500 all the rest i done is chrome and led lights thanks for tip will check this out
     
  6. robertc

    robertc Member

    83
    16
    0
    There was a recall on the 08 ultra fuel filter. My bike did the same. There was a small hairline crack that caused the problem. good luck!!!
     
  7. johnkarlfl

    johnkarlfl Active Member

    168
    0
    0
    how do I find out about the recall on the 08 ultra fuel filter??
     
  8. glider

    glider Veteran Member

    25,464
    108
    44
  9. monsterilg

    monsterilg New Member

    4
    0
    0
    got bike out today seems to be running fine put new intake seals and plug wires everthing seems ok find out more this weekend
     
  10. johnkarlfl

    johnkarlfl Active Member

    168
    0
    0
    thanks glider