2008 Electronic Throttle

Discussion in 'Touring Models' started by qman, Mar 9, 2008.

  1. qman

    qman New Member

    4
    11
    0
    I have a 2008 Street Glide with the electronic throttle.When I left the dealer it ran fine untill we stopped to eat. When I started it up the idle went up to 2000 RPM. It dropped back to 1500 RPM, it should idle at 1000 to 1100 RPM. It ran that way the rest of the day. The next time I rode it idled just fine. It has done this several more times and now has about 600 miles on it. This happens every 3rd or 4th time I go to start it up. I have had it to the dealer 3 times for this. They say that they cant find anything wrong with it. The last time they had it for 2 weeks. Has this happened to anyone else? The dealer says mabe it will quit on its own. This dosen't make sense to me. Any input would be helpfull.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Tell them you want a factory rep to look at the bike or else you want it replaced that you feel it is a safety issue.
     
  3. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
    Only have 200 miles on my 2008 SG but it hasn't happened to me ever. I agree - dealer's response is total BS!
     
  4. Crazyfrog

    Crazyfrog Active Member

    367
    26
    0
    I only have a measly 140 miles on my 08 ultra, no throttle issues. Do a google search on your states lemon law. Ohio is 3 times for the same problem. That should open their eyes a bit!
     
  5. freeman50

    freeman50 New Member

    3
    11
    0
    I had a similar problem with my 2008 Road Glide. I had unknowingly enabled the EITMS (enging idle temperature management system). This is described on page 140 of the touring model owners manual. I reset it according to the listed procedure and it corrected the problem.
     
  6. qman

    qman New Member

    4
    11
    0
    Thanks for the suggestions, I will try them out mabe one will work for me
     
  7. daharleyrdr

    daharleyrdr New Member

    4
    11
    0
    Freeman
    I checked it out on pg 140 the OM says "an optional dealer enabled calibration is available, see your dealer for details" so did you have the dealer do it or did youu? thanks Bill
     
  8. freeman50

    freeman50 New Member

    3
    11
    0
    The manual I have says nothing about optional dealer enabled calibration. It just explains what EITMS is and list the 4 steps to enable/disable the function.
    1. Turn the ignition switch to the on position (do not start the motorcycle).
    2. Push the throttle to roll-off position and hold.
    3. See figure 7. after approximately 3 seconds, the cruise indicator lamp will either flash greem (EITMS enabled) or red (EITMS disabled).
    4. Repeat the procedure as needed to enable or disable.
     
  9. ultraspark

    ultraspark New Member

    1
    11
    0
    I had the same issue "after" the 1K scheduled maintenance on 08 Ultra. When I cranked it to leave dealer, it burst idled to 2500...then down to 2000 rpm. The fellas told me it was "cold" and could shift by rolling "full off" on throttle to bring engine down to 1000. The next morning to take it back to the shop, it did the same thing...2500 rpm...air temp was 54F. The tech plugged it into the diag system, cranked it and it ran at 1000rpm. I thought I saw him roll full off on the throttle for a few...before cranking it. He might've reset the EITMS, but don't know for sure. It's idling fine ever since. I've enabled EITMS with no change in idle rpm...so far. The Harley techs are stratching their heads and are supposed to elevate to Harley electonics engineers. I'm not holding my breath...
     
  10. Vibratinharley

    Vibratinharley Junior Member

    428
    28
    1
    On the earlier 08 bikes I think before November 07, The Computer heat management system had to be done via a download from dealership, the later 08's can be done by the user following the procedure in manual.