2007 Ultra Classic Won't idle or dies when hot

Discussion in 'Engine, Fuel and Exhaust' started by HDJackson, May 15, 2014.

  1. HDJackson

    HDJackson New Member

    I have a question. I have a 2007 Ultra classic (its stock except for the SE 255 cam) that runs fine and idles fine in temps under 85 degrees. If the temp goes above 85 it idles about 500 RPMs or dies when you come to a stop. It will start right back up. I think it's getting too hot ... I've changed the spark plugs and they are the grey-ish white on both cylinders (sign of running too lean) I've changed the air filter, as well.
    I don't know how to fix it. Any suggestions or advice?
  2. tourbox

    tourbox Senior Member

    It could be going into Parade mode on Hot days. It may be the engine temp. sensor def. also.
    Have you checked it for codes and do you have a shop manual?
  3. HDJackson

    HDJackson New Member

    I checked for codes & it doesn't have any .... I don't have a shop manual. Do I need to take it to Harley to see if it's in parade mode??
  4. Breeze3at

    Breeze3at Well-Known Member

    The symptoms posted are a high probability of a dirty IAC (intake air control). Cleaning is simple, there is detailed procedure in the self help area.
  5. Jack Klarich

    Jack Klarich Expert Member

    [​IMG] Have a look here, #7 is the temp sensor, it is behind your horn on the back of the front head behind a rubber boot, this can cause the problems you are having, tho it should throw a code Welcome to The Forum
  6. Jennmarr

    Jennmarr Junior Member

    "Parade mode" is actually EITMS. That is an acronym for Engine Idle Temperature Management System. It will only engage when certain parameters are met. I do not remember the exact particulars, but in general the ECM will enter this mode when it senses engine temperature above a certain level, throttle position below a certain value and vehicle speed below a certain threshold. What the system does is to shut off the fuel to the rear cylinder and adjust the spark timing on the front cylinder to keep the engine running on one cylinder. This means that the rear cylinder is now just acting as an air pump to move relatively cooler air through the engine in order to bring the engine temperature down. It is rather effective. However, some people don't like it because the engine sounds like it is about to die when the system activates. Some also complain that it lags when it disengages. One last note, on the 2007 model year touring bikes the system can only be turned on or off by connecting a laptop. Starting with the '08 model year (throttle by wire) the system is rider controlled.
  7. dolt

    dolt Senior Member Contributor

    +1; I would clean the IAC port first.
  8. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

  9. HDJackson

    HDJackson New Member

    thanks everyone for your replies
  10. 03ultra45385

    03ultra45385 Active Member

    I am curious, how many miles are on your bike. You might want to check the Throttle Position Sensor, just to make sure it is operating correctly. It can be checked with an Ohm meter. You will be looking for a nice smooth change of resistance in the same direction from closed to open throttle. Most problems occur in the first few degrees of travel. I would also strongly recommend an oil temperature gauge as this is a good way to monitor your engine in conjunction with oil pressure and tachometer.