2007 dyna stalls at all red lights

Discussion in 'Dyna Models' started by Nightmission10, Jun 29, 2012.

  1. Nightmission10

    Nightmission10 Member

    8
    0
    0
    Gear down shut off 30 seconds fires up got to next light or stop sign stalls again seems more when real hot days just replace injectors yesterday at stealers.any anwsers Thanks Mike
     
  2. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
    Need all the info. Stage 1, mods, which tuner, how many miles on the bike? All the information is important. The more information you provide, the better quality help you will get.
     
  3. Nightmission10

    Nightmission10 Member

    8
    0
    0
    8000 miles vance and hines pipes only modsThank you for the reply This is my first bike i bought it from a soldier that had it in storage for 18 monthes buts ran sea foam though it and it ran ok the it foul out the rear cylinder plug so replace to no change took to dealer yeasterday said code was injectors replaced and ran fine yesterday Then today hot 100 plus ran great in am cool under90 then started staling light to light and will start up run strong no miss or anything just stalling and oh they adjusted my throttle thats pretty much the issue Thank for your reply and kindness Mike
     
  4. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
    When it does idle, does the idle vary up and down?
     
  5. Nightmission10

    Nightmission10 Member

    8
    0
    0
    Idles 1000 seems pretty steady no missing or back fire, and was back firing on decell before injectors changedthou.... it just like cuts off when I pull in the clutch at all stops But fires up like nothings wrong runs strong thing sensor maybe i dont know..Mike
     
  6. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
    Do you loose power when this happens? Light on, speedo working, etc? If you throttle it up will it stay running?
     
  7. Nightmission10

    Nightmission10 Member

    8
    0
    0
    Dyna runs fine great power idle come to light or a stop suddenly stall!!! turn off turn back on hit starter roll like a pearl.idles ok

    no lights on
     
    Last edited by a moderator: Jun 29, 2012
  8. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
    So you have to turn it off and turn it back on again for it to start? It wont just start by pushing starter button with out cycling the switch?
     
  9. Nightmission10

    Nightmission10 Member

    8
    0
    0
    Everythigs working runs great no lights on idle good just stalls at stops or redlights? got to be a simple problem i would think but a pain in traffic.thanks mike
     
  10. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    http://www.hdtalking.com/archive/t-46265.html Have a look at this, some 07 models slipped thru with out this FREE download, You can have a dealer run your VIN or go to Harley Davidson site and enter the VIN to see if your bike has been done, My 07 did the same thing you describe here