2007 cruise control problems

Discussion in 'Electrical' started by fwcole, Sep 27, 2011.

  1. fwcole

    fwcole Active Member

    189
    16
    0
    Hi. got a 2007 ultra classic with a cruise control problem ive been trying to work out. I have been following the flow chart to find the problem and have been unsuccessful. The flow chart points toward the set switch failing, but i have changed it and verified that there is no grounding problem between there and the cruise control module. my question is when testing for continuity at the module should the be/bl wire show continuity to the bl/ gr ground wire? in my opinion the shows the module to be bad, any thoughts?
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Don't have the manual for your year but a couple of months back a riding buddy had a problem getting the cruise control to set and stay set. His problem was in the front break lever switch.
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Number one on that Don, on the way to Sturgis my brothers 05 and a friends 10 model would kick out about every 40 miles or so Front brake switch problem. The old 1995 ultra I was on never missed a beat:s
     
  4. fwcole

    fwcole Active Member

    189
    16
    0
    thanks for the imput guys, thats just the problem, all the switchs and other potential problems are testing good as per the electrical diagnostic flow chart calls for. but when i hold the set switch on turn the ignition on the indicator light comes on to enter diagnostic mode just doesnt shut off when released. then with the switches testing ok, my thouhgts were that the module was letting the switch go to ground in the module.