2006 Heritage Front Brake Problem

Discussion in 'Softail Models' started by kh0027, Sep 14, 2009.

  1. kh0027

    kh0027 New Member

    2
    1
    0
    When my mechanic changed the handle bars, for some unknown reason it created a front brake problem. When the bike is off, I have full brake. As soon as I move it, or start it, I have absolutely no brake unless I pump it 3 or 4 times, then have full brake again. We have bled the lines, changed master cylinder, lines, calipers, re-bled, re-bled and re-bled, to no avail. I asked online experts, who suggested my rotor was warped, but that isn't the case. I've had two mechanics trying to figure it out and they're absolutely stumped, especially because I can have full brake, hold the lever in, and when I start it, lose the brake. Any suggestions? I rode out to Sturgis this way. A little tricky on Needles!
     
  2. springer03

    springer03 Active Member

    141
    16
    0
    Any problem at all with back brakes???
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Last edited: Sep 14, 2009
  4. Elmosac

    Elmosac Active Member

    174
    26
    0
    I know it is an 06, but do you have ABS on the bike? Just making sure you have stock brakes.
     
  5. kh0027

    kh0027 New Member

    2
    1
    0
    No problems with back brakes at all.

    No ABS
     
    Last edited by a moderator: Sep 16, 2009
  6. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    my vote is for air in the line. If you had your bars changed then my guess is you had your brake line changed, so unless you have a defective brake line (which I doubt because I would think that you would see it leak if it was bad) then you have air in your line. If your trying to bleed you brake line with out a power bleeder your gonna be fighting it for a while. :s

    Oh and by the way I'd find a new Mechanic. Brakes can be a pain but.........