2005 road glide wobble

Discussion in 'Touring Models' started by Dr.agony, Aug 5, 2010.

  1. Dr.agony

    Dr.agony New Member

    4
    0
    0
    need some input,got a 2005 road glide.front end starts to wobble after my hands are off the bar,balanced front wheel, tightned trple tree nut. still wobbling, well handlebars are shaking back and forth. thought of uneven fork oil but it has never been touched so it should have been stock implementation anyone heard of this before. Thanx:(
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    My 05RG has never given me any front end wobble, that has been a real strong point on the bike. How many miles on the bike? How many miles on the front tire? How was it balanced? Did you do the fall away procedure for the front end? You probably need to change the fork oil.
     
  3. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    High or low speed wobble , front tire tread cupping / uneven wear , warped rotor , brake piston not releasing completly, handle bars tight ???????
     
  4. revok1200

    revok1200 Active Member

    209
    28
    2
    Spoke rims? See if the spokes are loose.
     
  5. billnapabill

    billnapabill Active Member

    316
    28
    1
    Does it wobble all the time or just the first few miles? Does it sit for a long time or is it ridden daily? Have both tires been checked for tread separation? Was the rear tire balanced too?
     
  6. Dr.agony

    Dr.agony New Member

    4
    0
    0
    thanx for the replies but I already checked all that new tires brakes are good, tires balanced. I will do it if I am tooling along ,let go of the handlebars and just pull the bars a little it will start wobbling, back and forth.I can go 100 mph and hold on with one hand and its fine. I am a high speeder but if I hit a bump you can feel it ,wondering maybe the fork oil is uneven, just a thought ,. ,its not like I havnt been ridin ,been doin it for many many years but this one has stumped me, I am really fussy with everything but I feel I am missing something. any other educated guesses let me know. Thank You
     
  7. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Like I said earlier my front end has always been solid. I did have a high speed wobble that I cured by adding a rear stabilizer. Mine is from TWR, but progressive and several others are selling them. Since I added the link my RG feels like it's on a rail on the stright stuff and the twisties. With the cruise set hands off the bike feels solid no shakes.
     
  8. Pokerstar

    Pokerstar New Member

    1
    0
    0
    The MoCo has issued a service bulletin on 2009 Touring models regarding the adjustment of the steering head bearings. In reading the symptoms and solutions, this issue sounds like it could be a steering head bearing mis-adjustment. One other thing to check is your front tire for wear, out of round or tread separation. (The service bulletin # is M-1246 for reference)
     
  9. ironmark

    ironmark Junior Member

    754
    28
    4
    Your bike is a 05 have you greased the front bearing at all ?? If not the font bearings may be wearing out .
     
  10. glen073

    glen073 Active Member

    176
    26
    0
    Have an 04 Road Glide with 103K on it that's stable at all speeds unless the Tour Pak is on. Then it will do the same thing at speeds under 30 MPH.