2004 Sportster won't fire

Discussion in 'Sportster Models' started by Wolfclan1959, Aug 2, 2009.

  1. Wolfclan1959

    Wolfclan1959 New Member

    Parked bike,Went back to start and take off.Bike won't fire at all.Battery fully charged,Power to coil but no spark to either cylinder.Swapped coil from another bike,still the same as well as changing starter control module also was changed out.Old ones are good as they work and start other bike.Driving me nuts!! Help,Please

    NEWHD74FAN Experienced Member Retired Moderators

    Welcome to HDTalking, you will find a large pool of experience and knowledge to help you to make your riding experience enjoyable. There are a number of things to try, but first I would check the fuse box...it is open to weathering and corrosion can cause intermittant problems. Use contact cleaner and clean or replace the fuses (plugging and unplugging should be fine) and the relay. Also check all 6 primary cable connections (neutralize with baking soda and scrape w/ pocket knife) Red, Black & Starter cable.

    Sometimes what DOES work can help troubleshooting...do the turn signals works, are there any diagnostic codes that flash on the speedo display, is your bike equipped with immobilizer? Was there recent controls or electrical work done near the engine kill switch, tail light or main harness or added accessories...peripheral damage may have been done. Yep, a lot of stuff can be done yourself, but the real big thing is, do you have a MOCO Service Manual...it is worth it's weight in gold right now...
  3. Wolfclan1959

    Wolfclan1959 New Member

    Thanks man,Yes to all,Have manuals,all lights work,Cleaned all you said already.Wonder if it may be crank position sensor? Power to coil but no fire. Its driving me nuts.Thanks again.
  4. glider

    glider Veteran Member

    CPS is a good candidate with no spark at the plugs but power to the coil.