2004 Dyna vibration

Discussion in 'Dyna Models' started by edmis10, Sep 26, 2011.

  1. edmis10

    edmis10 New Member

    4
    0
    0
    I have recently replaced leaking seals on my 2004 Dyna low rider. I, at the same time changed the lube to HD Syn3 in all three holes. Since reassembly, I have noticed a vibration in all gears at around 2000 rpm. It runs smooth when cold, but begins to vibrate after about 30 min of riding. When I first noticed it, I suspected that I had missed something during reassembly, so I took it back down and did it again. Still there. I had also remapped the Commander III EFI to match the bikes exaust and air. The original map was for stock and I am running Python full exhaust and Screaming Eagle air. Temporarily put the old map back in. Still there. Looking for ideas.
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    What were you running for lube in your trans and engine oil? I would not recommend syn3 in all areas.
     
  3. edmis10

    edmis10 New Member

    4
    0
    0
    I don't know what the previous owner had in the bike. I presume gear lube in the chaincase and HD lube in the engine and tranny. What do you recommend?
     
  4. Spade5

    Spade5 Active Member

    236
    26
    0
    I personally think HD Formula+ is fine in the primary and transmission. There may be better after market choices but I'm not going there.

    Even though HD said Syn3 in all three holes for some models, I think they backed off of that.

    I am sure others will give you some suggestions.
     
  5. edmis10

    edmis10 New Member

    4
    0
    0
    From what I have read recently, I think that your advice is sound.. I'm going to change the chaincase and tranny lube asap. Thanks
     
  6. wilks3

    wilks3 Junior Member

    623
    0
    1
    I use;
    Engine/Lucas Synthetic 50wt
    Trans/Redline Synthetic Heavy Shockproof 75W140
    Primary/Mobile1 4t 10W40, OK for wet clutch's
    wilks3
    :USA