2003 FLHTCUI is possessed with an electric gremlin

Discussion in 'Electrical' started by YZman, Apr 11, 2008.

  1. YZman

    YZman New Member

    1
    11
    0
    I have a 03 Ultra Classic. No problems until I put on the aftermarket Kuryakin horns that fit behind the right saddlebag. I had previously had the dealer install a parade fan so I could not route the wires to the original horn position but wired into the relocated horn position inside the fairing. It wacked out after a 150 mile trip.

    Low beam doesn't work (bulb was fine).
    Volt gauge light doesn't work
    Left turn signal did not work
    Horn did not work.

    Now, turn signal works again as does the horn. No low beam or volt gauge light. Went out yesterday and turned on the ignition and everything worked (to include low beam). Went out today and low beam and Volt gauge light don't work. Did not start it or anything.

    Any help is appreciated.
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    You have been inside the fairing and with the problems you are having , I would look for a loose or bad ground. Also check to see if the ground strap that may be at the bottom of the risers is intact too. It furnishes the ground to everything on the front end. Also check the individual grounds too inside the fairing.

    Try this, get a piece of 14 gauge wire and connect one end to the negative of the battery and touch the other end to the bars and see if everything works then. It's a quick way of testing the bike ground to the bars to see if that's the problem.