2003 Deuce Check Eng Light Flashing.

Discussion in 'Engine, Fuel and Exhaust' started by BCJ58, Apr 23, 2008.

  1. BCJ58

    BCJ58 Member

    6
    11
    0
    For starters new to your site would like to say HI to all. :60:My 2003 Deuce has the check eng light showing a historic code. After I select run and Ing. the eng light comes on, the fuel system pump runs up and the light goes out. Then a few seconds later the check eng light comes back on for 8-10 seconds and then goes back off. Bike runs great. A little history just had the chain cams replaced with gear cams , has a DFO installed and I beleive it is a Stage I breather, and magnum plug wires. The day before I noticed the check eng light, the eng did back fire, and when I went to put gas in after the back fire I noticed the eng light cam on, and a code went buy the odomiter but it went away. The next day I noticed the eng light coming on every time I started the eng with a historic indication. Put a Scanalyzer on bike and the eng light flashed the historic indication, and then went out, but no code could be read by Scanalyzer. From the info I have found on your site is this not a problem, and I just have to wait the 50 cycles to see what happen. But if the problem is causing the historic indication each time how can I find out what might be the problem, short of replacing items.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. BCJ58

    BCJ58 Member

    6
    11
    0
    No I did read it and have the procedure was wondering if the scaner did not pick up a code will this procedure show one. I did take the mag wires off and installed the old ones and the code still showed. If I suspect the wires will I have to leave the mag wires off for 50 cycles to see it this is it, then put the mag wires back on when the code clears, and see what happens. Thanks for the help.
     
    Last edited: Apr 23, 2008
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Worth a try using this procedure. If you didn't clear a code that may have been there, it will still show regardless of the wires and leaving them off will clear a code after 50 start and run cycles of at least 30 seconds each.
     
  5. BCJ58

    BCJ58 Member

    6
    11
    0
    I just did the code check out and the light still comes on but there is no code stored. Is it possible I have an electrical problem or does the light need to go thru 50 cycles. Thanks you really help, given me a better understanding of the system.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    If there's no code stored, I would wait for the 50 cycles and see what you get then. The dealer can put the light out but they usually charge for it unless you have a good dealer.
     
  7. BCJ58

    BCJ58 Member

    6
    11
    0
    We tryed to put the light out with a scan but it would not go out. Guess Ill wait 50 cycles.Thanks