2001 Ultra problems

Discussion in 'Touring Models' started by tank55, Apr 7, 2012.

  1. tank55

    tank55 Member

    5
    0
    0
    I drive a 2001 Ultra Classic , today I started it up just like every other day ,
    let it warm up while I put my jacket and helmet on then got on it and started to pull away, as I did the motor quit and at first I thought I had stalled it but when I tried to restart it would fire up and die. when I turn the ignition on I hear the fuel pump run and the tank is full. Any ideas?
     
  2. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,019
    68
    32
    Open the fuel cap and then turn on the ignition.If you see the fuel swirlling in the tank or hear a hissing sound you will need to replace your high pressure fuel line in the tank.Make sure when you replace it that you do so with an ethenol resistant line:s
     
  3. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,220
    58
    96
    What Steve said. Sounds like bad fuel line for sure.
     
  4. tank55

    tank55 Member

    5
    0
    0
    Thanks I'll try it when I get off work tomorrow
     
  5. brownfoxx1

    brownfoxx1 Active Member

    262
    26
    0
    DOES THIS HAVE THE KICK STAND SENSOR?
    OUT OF ADJ?FUEL VENY PLUGED
    tmap, ckp,or O2 sensor bad
    when you have time go thru the bike and ck for loose grounds , and unhook all elec connections & put a dab of die-electrical grease in them
    . just suggestions
    .check out troubleshooting problems vtwinforume,comas well as triketalk.com
     
    Last edited: Apr 8, 2012
  6. tank55

    tank55 Member

    5
    0
    0
    I found that if I take the air filter off it will start and run but now my tach doesn't work and my check engine light stays on, this is not my first touring bike but, it's my first Harley and it's harder to troubleshoot so I would appreciate anyone who could help me out, I want to be riding it not working on it.......Thanks
     
  7. mrmagoo

    mrmagoo New Member

    1
    0
    0
    2001 Harley Ultra Classic.

    I recently drove from Louisville, KY. to Lexington,KY. for the 2014 HOG State Rally. A trip of less than 100 miles. While in route on the Blue Grass Parkway my engine light came on. It stayed on for only a few minutes the went off. Never lost power during the time the light was on. Was maintaining a speed of 65-70 miles per hour. The light came on 3 or 4 times for the same short period of time. When I arrived at the motel, checked in and then proceeded to take the bike to the local dealership. When I started the bike the idol went way up but the tach never moved. After a few seconds the idol lowered and the engine died. The bike wouldn't start for 15 or 20 minutes. Finally got it started only to go a few feet and it died. Currently have at a dealer but they are having trouble locating the problem. Need your help please!
     
  8. wannaride

    wannaride Active Member

    259
    28
    2
    If you have a owners manual, pull codes is the best place to start. On my 99 Ultra you have to turn on, off & on (if I remember correctly) & it will start flashing longs [10's] [ short flashes [1's] (2 longs 3 shorts would be 23). You can also spray some flammable brake clean in the throttle body & if it stay's running, it's a fuel problem. If it doesn't run, look at ignition.

    Toby
     
  9. Jack Klarich

    Jack Klarich Expert Member Contributor

    17,837
    153
    261
    This sure sounds like a fuel problem, I would be very surprised if the techs do not find the problem right away