2001 Road King Classic Check engine light questions.

Discussion in 'Touring Models' started by Plettieri, Jun 26, 2011.

  1. Plettieri

    Plettieri New Member

    3
    0
    0
    I have an 01' road king classic fuel injected. I have it set up with V&H true duels and PC. I just picked up the bike this past January.

    The previous owner had told me that every once in awhile it registers a code from a mis-start. Also, sometimes the bike shakes after at idle after he went to the true duels.

    Anyway, I've been riding the bike with no issues so far. I have experienced the shaking but it doesn't do it all the time. The other day I decided to take it on a good long ride. I noticed that it was registering a historic code but I figured it was from the starting issue. About 45min into the ride, the check engine light would come on and stay on for about 30 seconds or so and then go off. The longer I rode that day, the more frequent it would do it.

    So I figured I'd clear all the codes and try to get the engine light to come back on and check that code. I unplugged the main harness for about 30 seconds and that cleared the codes. I rode it for another 2 hr's and the bike ran perfect and the check engine light never came back on. I even noticed that it was idling much lower and barely shook at all during idle.

    Any ideas??? I really appreciate any feedback you could give me on this issue. Thanks!
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    The key thing here is to register the code and see where it takes you. Without that it's difficult to determine what is causing the problem .How are the plugs and plug wires. You mention shaking when starting? Is it like a dead cylinder or just roughness at idle. How is the throttle response when it is shaking? Check for an intake leak?

    The historic code is what may tell the story. 50 start and run cycles of at last 30 seconds will clear that too if the fault doesn't reoccur.
     
  3. Plettieri

    Plettieri New Member

    3
    0
    0
    There were no codes coming back up after I cleared them. It's more of a rough idle. I noticed that it will idle up around 1000-1100 and the motor shakes. It really only does it at idle and the bike runs fine at all other RPM's.
    Plugs look good and all wires seem to be secure.
     
  4. glider

    glider Veteran Member

    25,464
    108
    43
    Looks as far as plugs and wires can be very misleading. You need to either replace them or check the resistance in the wires to be sure. Check for an intake leak also which would give you a rough idle but run pretty much OK otherwise.
     
  5. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,370
    133
    150
    Your idle should be around 1000RPM, does it idle lower than this? Your shake could be the front motor mount.
     
  6. Plettieri

    Plettieri New Member

    3
    0
    0
    It usually idles around 900-1000. The funny thing was that immediately after I cleared all the codes, the bike ran perfect. I don't get it.
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Being able to clear DTC codes by removing power on a MM system.? Was not aware of that and really don't see it working. It would only make sense that they would be stored in non-volatile memory.