2001 883 Hugger Speedo issue

Discussion in 'Sportster Models' started by Juggz, Sep 4, 2014.

  1. Juggz

    Juggz New Member

    2
    0
    0
    Wife's speedo started reading 20mph under what she was actually going. Haven't had a chance to dig into it yet, wanna do get some info before I do. Never messed with it before, any good pointers?
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    With speedo being electronic I can not understand how it would change so drastically out of the blue. Is there any check engine light, or mods done to bike before issued started. Change in wheels or tire size?
     
  3. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,316
    73
    130
    Check the VSS vehicle speed sensor for fuzz. It may be whats causing your issue. On your model I think its kind of hidden up under the starter. Its magnetic and will pick up any metallic debris that maybe going by.
     
  4. Juggz

    Juggz New Member

    2
    0
    0
    No changes except her paint. Still stock so far. I'll check the VSS this week, supposed to be raining so It'll give me something to do. Appreciate the info.
     
  5. DFHarley19

    DFHarley19 Active Member

    390
    0
    0
    I did clean up my VSS (under the starter) and did not help but mine is only 4 or 5 mph slower just like most of other HD bikes. Yours is off by 20 mph and I think it ( hope so) will help you. Also, I am curious to know where is the VSS mounted on your bike. Thanks.
     
  6. 03HD883R

    03HD883R Active Member

    167
    0
    0
    The speed-sensor is mounted on the right side of the transmission cases, just below the starter.