1999 FXDX Carb Troubles

Discussion in 'Dyna Models' started by g83lowrider, Apr 5, 2011.

  1. g83lowrider

    g83lowrider New Member

    I bought the bike about 2 years ago enjoying the heck out of it....
    It is a 1450 with a "from what I was told" Screaming Eagle Kit put on it... Have never had the engine apart myself to know for sure what all has been done to it... From all I can tell it has a K&N Filter put on it and Screaming Eagle II pipes put on it... The baffles have been taken out of the mufflers and has been recently rejetted for it when the head work was done...
    Since I have got it back from the shop I took it to "No Name of Place" it ran great for about 300 miles or so... Recently I have been having troubles with it, I have taken the carb off and made sure it was all clean and fresh gas put in the tack with new filter and all so I know it is not from loose debree from letting it sit for a year...

    Trouble is this... It starts and Idles just fine, no troubles at all... As soon as it warms up for about 5 minutes or so I deside to take off and when I do start putting a load on the bike it seems to want to stall and die... If I take the RPM's up to around 2 or so it does not have any troubles at all.. It seems to be only at the lower RPM's that I am having troubles... Is it as simple as setting a idle mixing screw ( whitch it was done when the head was done )...

    Can some one at least point me in the correct direction to look for a problem...

    Thanks alot.... Harley Rider for Life.............
  2. glider

    glider Veteran Member

    It sounds like the low speed circuit that is giving you a problem or an intake leak.

    There's numerous posts in the self help area that will show you how to check out the carb and an intake leak too.

    Use the link at the bottom of this post.
  3. Jack Klarich

    Jack Klarich Expert Member

    CV Carburetor Jet Adjustment/Trouble Shooting - Harley Davidson Community Self Help Section:s
  4. jaxdwg

    jaxdwg Active Member

    Raise the needle. 2 "#4" washers under the needle should take care of that problem. the taper on the needle is too slight and it goes lean and coughs at light throttle settings. That's why it runs fine higher up the rpms and idles good too, because you are on the idle circuit. the transition from idle to main jet is where the lean condition comes in with the stock needle and the two washers should raise the taper and make it a little richer during the transition.-----jack