1999 Fatboy blinkers

Discussion in 'Softail Models' started by Duffmiester, May 5, 2010.

  1. Duffmiester

    Duffmiester Member

    25
    11
    0
    I recently bought my wife a 1999 Fatboy and we are having some blinker issues. Has anyone ever had a situation where the blinkers work fine with just the ignition on and not blink once the the bike is started. You can turn off the bike again and the blinkers work as advertised. I would appriciate any comments.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    That sounds strange. What is the voltage across the battery with the engine running at 1500 RPM.
    Has the blinker system been modified from factory stock.
     
  3. Duffmiester

    Duffmiester Member

    25
    11
    0
    Not sure of the voltage across the battery and I don't think the blinkers have been modified. I will check on the voltage this afternoon though.
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    I could tell you a lot more if I had a wiring diagram of your bike. This 1999 is a FLSTF correct?
     
  5. Duffmiester

    Duffmiester Member

    25
    11
    0
    Yep thats it.
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    If you happen to find a link that shows your wiring diagram, post it. I will see what I can find till you get back with the voltage reading.

    So you don't have any brake light turn signal converters or LED's with load resistors or sequential turn signal black boxes as far as you know.

    If it is truly stock, it should be a quick fix (or at least identify the bad part) with a wiring diagram.