1997 road king won't start

Discussion in 'Touring Models' started by 97rkdoug, Aug 15, 2009.

  1. 97rkdoug

    97rkdoug New Member

    2
    1
    0
    I have a 1997 road king turned the ignition on hit the start button, nothing happened, checked the on/off switch it was in the on position still nothing.
    I noticed my engine light was flashing I hit the start button engine turned over but would not start, after turning the ignition switch on and off several times the light came on as normal and the bike fired. The bike is injected and the fuel pump would start each time I switched the bike on but at frist nothing happened then it turned over but wouldn't start, then finally it started as normal. Any advice would be appreciated.
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Remove and clean both mating surfaces of the battery cables (remove neg first put back on last) on both end of each cable. Inspect these cables carefully for corrosion (like under the insulation at the ends).

    You may want to dissassemble your bar switches on the right side. I would bet there is a bunch of green corrosion salts on the copper. Scrape that off, spray with electrical contact cleaner, spray with lube, then reassemble.

    Check to see if you have any historic codes stored.

    TQ
     
  3. 97rkdoug

    97rkdoug New Member

    2
    1
    0
    Thanks so much TQ. I will try all this today. I am right now searching to find how to clear historic codes if I have any.