1997 flhtcui engine light on

Discussion in 'Electrical' started by daytonatwelve, Oct 20, 2008.

  1. daytonatwelve

    daytonatwelve Member

    5
    11
    0
    Help !!!

    Had the tank off this weekend and hoisted the bike up by the top tube whilst aligning engine etc. Also fitted free flowing exhausts at the same time.
    The engine management light comes on whilst the system pressurises, goes off briefly then comes on and stays on even before starting. Light stays on permenantly and the bike is flat out at 95mph and holding back.
    Have i disturbed something and if so what?
    How can i read the fault?
    Also can the ecu be programmed for free flowing pipes and filter?

    Be gentle with me its my first time!!
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Welcome aboard!!

    Check this out:

    Checking TSM/TSSM Trouble Codes - Harley Davidson Community

    Also, your question about remapping, here is some discussion:

    Remapping - Harley Davidson Community
    When To Recalibrate The ECM - Harley Davidson Community

    A simple user-friendly system that allows you to "tune" the injection system similar to adjusting a carburetor is here:

    TFI Questions - Harley Davidson Community

    More discussion:

    EFI Tuner Comparisons - Harley Davidson Community

    As a general recommendation, see the self-help tips section with the link at the top of the page (Quick Links Tips Forums)

    TQ
     
  3. daytonatwelve

    daytonatwelve Member

    5
    11
    0
    Hi TQ
    Thanks for the quick reply, will check out later. Read the self help section first but was'nt sure which info related to my model / year / injection type.

    Cheers.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
  5. daytonatwelve

    daytonatwelve Member

    5
    11
    0
    Hello again

    Have tried both methods and no luck, the bike has a Magnetti Marelli fuel injection system, any more ideas ?.

    Thanks
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    It was a shot in the dark but I believe the self diags started in 99 but it was worth a try.
     
  7. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Unfortunate that we can't figure out how to read the codes, but that aside, something must have happened this past weekend that is now resulting in the trouble code indication. Retrace your steps in removing the tank, and suspending the bike by the center structural member. Did a sensor wire or injector wire become disconnected or pinched? Has everything been reconnected correctly? If everything is connected correctly, and there is no obvious damaged wire to any sensor or the injectors etc., then I am afraid that you will be forced to take the bike in to a dealership to have them read the codes for you. May cost an hour or so of service time, but they should tell you what the code is. Then you can decide to fix it yourself, or pay them to do it.

    TQ
     
  8. daytonatwelve

    daytonatwelve Member

    5
    11
    0
    Thanks again for trying to help, beginning to wish I had never seen the thing what with the severe vibrations coming through the tour pack at 1000 to 2000 rpm (hence the front engine mount change and re-alignement) changed the mount for a Zodiac part with the original 79B part No. (rock hard compared to the original mount) now the vibration is even worst. Plus after the severe thrashing at the weekend in frustration at the light and vibration, the base gaskets appear to be weaping. Should have held out for a twin cam ( or just throw the luggage over the deuce for any future road trips ).