1988 883 Deluxe turn signal & brake light not working

Discussion in 'Electrical' started by 88sportyXLH, Dec 19, 2013.

  1. 88sportyXLH

    88sportyXLH New Member

    1
    0
    0
    I am a new rider and just bought my first bike ('88 XLH883DLX). The front turn signals had already been removed, tho I see the connection points for each just below the speedometer. The rear signals do not light at all on either side.

    The tail light, headlamp, horn, speedo and all indicator lamps work fine.

    The brake light WAS working the day I got it, but has since quit illuminating regardless of front or rear brake application.

    I have checked the bulbs and wiring that is visible under the rear fender and removed the seat to check for exposed wires/connections and circuit breakers.

    I'm at a loss and hoping someone has some pointers??

    Thanks!
     
  2. tourbox

    tourbox Senior Member

    1,307
    68
    54
    The connections under your speedo are for the blinker indicators. The actual wiring for the front blinkers should be inside the head light. You should also find the flasher unit in there. There will be a 4 or 5 wire plug coming out of the fender near your battery box. The blue wire is for tail light,violet for left turn,brown for right, and maybe a red or green for brake light. If there is a black it would be ground. Check each of these with a 12V. test light for voltage as you go through their function.
    And by the way, Welcome to the forum from So. Texas.
    tourbox
     
    1 person likes this.
  3. r_k_dragon

    r_k_dragon Active Member

    270
    0
    4
    Welcome to the forum from the southwest desert and congrats on the 883!
     
  4. Breeze3at

    Breeze3at Well-Known Member

    4,641
    83
    122
    Also note that 1988's had to have the button held down for signal activation. They did not have self cancelling signals.
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
    [​IMG] Here is a wire diagram if it helps