1984 FLHTC turn signals won't flash with headlight on

Discussion in 'Electrical' started by ezrydr58, Mar 26, 2011.

  1. ezrydr58

    ezrydr58 Member

    10
    0
    0
    Hi Guys,
    I'm kinda new here and I hope this is the right place to post this question.
    I've got a 1984 FLHTC. I don't know if this makes any difference but in the interest of full disclosure this scooter is a mid-year model and has the evo engine with the dry primary. For all intents and purposes I think it is the same chassis as the shovelheads only with the evo engine.
    I've had this bike for 25 years and managed to do all my own fixing so far but this one's got me stumped.
    Here's the deal, my turn signals flash slowly when I don't have the headlight turned on. As soon as I switch the headlights on they stop flashing and go on steady.
    I've replaced the flasher module - no difference.
    These stock signals are already a pain since ya have to hold the button down to keep them flashing but now I have to press/release/press/release just to make em look like they're flashing.

    Any of you guys got an idea as to where I need to look to fix this?


    Thanks,
    Steve
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Check out the voltage at the battery when Idling and then at about 1500 RPM's and see what you get. Should be a bit above 14V with some engine speed.

    It could be a low voltage problem due to low output or weak battery.

    If you raise the RPM when the signals stop flashing, will they start to flash again?
     
  3. ezrydr58

    ezrydr58 Member

    10
    0
    0
    thanks Glider - I'll check this