1200C Electrical Problem

Discussion in 'Sportster Models' started by CoryC, Sep 3, 2007.

  1. CoryC

    CoryC New Member

    2
    11
    0
    I just bought an '07 1200C that won't start. It has just over 1,000 miles on it and the dealership just installed a new clutch switch. When we stopped and I tried to start the bike again it did not start the first time and the electrical system shut off. Luckily, when I turned the key to the 'off' position and back to run, the electrical system worked and the bike started.

    However, two days later, I cannot get the bike to start at all. This time, when I turned the key to run the lights all came on, but when I hit the start button I hear one loud click and all the electrical components went dead. The power came back on after checking the battery connectors, but again, a loud click and all power went off.

    Any idea what is happening?

    Thanks
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    That sounds as if you have a loose or dirty battery connection if the power goes off when you try to start it. The loud sound you hear when you tried to start it could have been the starter dis engaging as the power cut off. Remove, clean (wire brush) and replace the battery connections and also if you can get to the other end of the cables, do the same thing here too. It's a very common problem.

    There was a problem with the fuel pressure regulators on that bike but I don't think that is your problem here.

    You may find some useful tips here too besides the rest of that forum.

    http://www.hdtalking.com/electrical_and_lighting_systems/1251-engine_does_not_start.html
     
    Last edited: Sep 3, 2007
  3. CoryC

    CoryC New Member

    2
    11
    0
    Thanks! :D

    Got it started after checking the battery connectors again and when we stopped, the same thing happened - except this time we could see sparks coming off of the negative connector.

    Tomorrow (since it is now dark and there are no lights in the garage) we will clean and tighten the negative side too.
     
  4. glider

    glider Veteran Member

    25,464
    108
    43
    Way to go !:s
     
  5. Roy-Ark

    Roy-Ark Member

    8
    11
    0
    The loud click you here is the circuit breaker kicking out.
    This prevents an overload from melting the wireing.
    You have a dead short in the starting system.
    There are several circuit breakers.
    You need a service manual so you will know exactly which breaker is kicking off.. Then you can trace the wires from the "breaking circuit breaker" to find the short.
    EZRYDE