'11 Fat Bob front brake buzzing

Discussion in 'Wheels' started by Big Stan, Apr 24, 2011.

  1. Big Stan

    Big Stan Member

    Picked up a 2011 FXDF and it seems to have developed a buzzing sound when I apply the front brakes. No surging or softness in the lever, just an annoying buzz.... Had 10 miles on the bike when they pushed it off the dealer floor for me and has about 260 on it so far. I have been very cautious about properly breaking this bike in since I plan on keeping it for many years to come.
    Is this a normal break-in quirk or should I bring this up to my dealer/servicer?
    I planned on waiting til the 500mi mark, but with the complement of informed individuals that seem to be on here, I see no harm in asking.

  2. Joyflyin

    Joyflyin Experienced Member Staff Member Moderator

    I'm not much help here mechanically, but if it seems unusual, I would bring it up to the dealer just to have it on the record.
  3. glider

    glider Veteran Member

    You will get some buzzing noises from the cross drilling in the rotor but you may want to have the dealer check it over to see if it is normal.
  4. craig Lee

    craig Lee Active Member

    I really noticed my high pitched fluttering or "buzzing" when I switched from OEM pads to Lyndall Z+'s. Especially in the front since my SG is dual caliper.
    Tells me the pads are really doing there job.:D
  5. Jack Klarich

    Jack Klarich Expert Member

    The floating rotors seem to do this more often, it is a harmonic from pad vibration. You can have the dealer look at it if it is a warranty issue, or apply some silicone paste or anti sieze to the backing plates of the pads this should help:s
  6. Big Stan

    Big Stan Member

    Thank you all for the inputs. Gonna put a bit of anti-squeal on the pads to see if that cures it. Ill have the dealer look at it at the 1,000mi service if this works, if not it looks like I have yet another excuse to ride!

    Thanks again
  7. FerrousBueller

    FerrousBueller Junior Member

    Big Stan,

    Hope you don't mind me piggy backing on your thread.

    I have a similar noise on my bike. Dealer said they couldn't find/hear it at 1K service. My noise is most noticeable at 40 to 45MPH. It will happen when coasting, engine off. It sounds like an old stovetop mechanical buzzer. It's done it since I've had it. Seems quieter now, or, I just ignore it better. Bike: 2009 Softail Custom.

    I'm curious if your noise is similar to mine.
  8. Big Stan

    Big Stan Member

    It sounds like we have the same annoying voice coming from the front end my friend.
    I live in Hawaii but am in Arizona for work right now. but when I get back in a couple weeks I am going to take a deburrer to the cross drillings in the front rotors and knock the hard edges off of the holes.
    Hopefully it will help and not be a huge waste of time. I'll let everyone know how it turns out. If you get to it before me, please share the info!
  9. wilks3

    wilks3 Junior Member

    My 2010 FatBoy did same thing, noise went away after about 800/1000 miles.
  10. FerrousBueller

    FerrousBueller Junior Member

    I'm just a little over the 2K mark, paid a little more attention and the noise is still there today. I can hear it even with earplugs in. Gonna try Jack's remedy perhaps next week. Deburring the holes in the rotor seems a little dicey to me.
    Last edited: Apr 26, 2011