09 FXDF Issue

Discussion in 'Dyna Models' started by Hognewbie, Jun 19, 2010.

  1. Hognewbie

    Hognewbie Member

    10
    0
    0
    I've had my FB since 09 and only have about 1100 miles on it. I would have move but haven't been riding as I have an issue that nobody seems to know how to fix.

    When I ride I have no issues but as I downshift or decel I get this really bad shaking or shuddering that seems to be coming from the engine area, not a vibration, but it shakes the whole bike.

    To me it seems like the clutch is not grabbing properly. I'm not a motorcycle mechanic and am the 1st to admit I don't know much. I've had it in the dealer and they claim they don't feel it, but it happens every time I ride.

    The bike didn't do this before and only just started the last few times I rode. I checked the bolts that connect the motor mounts to the frame and they are nice and tight. I just don't know where to look.

    Any help from anyone would be great.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Check the exhaust system. Any mods since it started doing this? What mufflers do you have?
     
  3. Hognewbie

    Hognewbie Member

    10
    0
    0
    Thanks for the input...I have rush slipons with a PCV. I have checked all the connections on the exhaust and they are tight.

    I think I may have to try a different dealer.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    The change in slipons or exhaust will give you a sensation of something being loose on decel over the stock parts.
     
  5. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Hobbit, was this on ALL TCs of the 09 vintage?

    signed....BUBBIE
     
  6. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
  7. shovelrider

    shovelrider Member

    49
    0
    0
    Had a Dyna with a similar problem years ago & what we found was a small rock wedged into the rear engine mount.Just a thought that might help.:D
     
  8. Hognewbie

    Hognewbie Member

    10
    0
    0
    Took it to a different dealer yesterday. Thought I also heard some rattling and knocking down by the primary while riding. Let ya know what they find if ya interested.
     
  9. glider

    glider Veteran Member

    25,464
    108
    44
    By all means let us know what they find.
     
  10. Hognewbie

    Hognewbie Member

    10
    0
    0
    Ok so I talked to the dealer on Thursday and they claim they rode it for about 12 miles and found nothing out of the ordinary. They were going to call corporate tech support to see if they had any ideas.

    I know these problems exist. The bike wasn’t doing this before so I just don’t understand why I’m the only one who sees the issues. URRRRRRGH!!!!