'08 SG DTC code P1511 and P2135

Discussion in 'Touring Models' started by craig Lee, May 31, 2009.

  1. craig Lee

    craig Lee Active Member

    269
    28
    1
    Hey Guys,
    My throttle lost control today on my '08 SG (26,000+ miles). Turned bike off and started and ran great all day. Code P1511 Throttle control power management failure of throttle control actuator and P2135 TPS Correlation Error is stored.

    Any ideas in what I'm in store for.

    Thanks Glider for the info on the codes within the website.

    Craig
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    It all depends on the dealer you use. It could be anything from "they all do that" to a replacement actuator/module.
     
  3. craig Lee

    craig Lee Active Member

    269
    28
    1
    Hi Glider,
    Just brought the bike home from the Dealer. Said it was a pinched wire in the chrome switch housing cover. Warranty since they installed the covers 18 months ago. We'll see if this does it.
    Thanks,
    Craig
     
  4. glider

    glider Veteran Member

    25,464
    108
    43
    Glad it wasn't anything more.
     
    1 person likes this.
  5. craig Lee

    craig Lee Active Member

    269
    28
    1
    Well, it's been 10,000 miles (36,000) and code P1511 and P2135 came up again along with C1095.
    We'll see where we go from here.
     
  6. craig Lee

    craig Lee Active Member

    269
    28
    1
    Just brought the bike home from the dealer and talked to the mechanic. He explained it was the 2nd bike for him this week with codes 1511 and 2135. He said Harley Tech Support is seeing this more and more with high mileage '08's.
    They said it is the wires in the connector to the TCA. With condensation, weather, etc. there is a build up. He replaced 4 wire connectors to that connector. Someone mentioned in another thread to pull that connector and clean it. That might be a good start. My mechanic did say Harley is trying to find a cure for this since it is happening more and more often. We'll see.

    The code C1095 was cleared and had no explanation at this time.

    Hope this helps out for future 1511 and 2135 Code Bearers.
     
  7. jaceddie

    jaceddie Junior Member

    930
    28
    1
    Thanks for this post. I'm having the same problem on my 09 UC with 20k miles. When it started, the throttle would not respond at all. After shutting the bike off a couple of times, I still got the check engine light, but the throttle worked. Called my dealer to set up an appointment, but will have to wait until April 24th to get it in. Hope this leaves enough time to get it fixed. We are leaving for a month long trek to the west coast the first of May.
     
  8. craig Lee

    craig Lee Active Member

    269
    28
    1
    Happy this thread helped. This forum is the bomb and that's why we continue to support it and the members. Maybe print this thread out when you take the bike in. If you're in Southern Cal., feel free to look us up. We get around a lot and Mz Bling is easy to spot. :)
     
  9. jaceddie

    jaceddie Junior Member

    930
    28
    1
    Here's a update on the problem I was having. I ordered a replacement Sensor kit that has a new throttle control and new wiring. The old sensor had a connector that was inside the handlebars and that was what, I think, was causing the problem. The new sensor has longer wiring and no mid wire connector. Put it in today, and it's working great with no codes. The HD part number is 32310-08. Will update this again if any problems show up.
     
  10. BigMike57

    BigMike57 Member

    22
    11
    0
    Is this a problem with all '08 dressers or just because of the chrome cover that was installed? I just went over 37,000 with my '08 Ultra and nothing yet!