08 road glide electrical trouble

Discussion in 'Electrical' started by danno138, Feb 8, 2009.

  1. danno138

    danno138 Member

    8
    11
    0
    my 08 glide has a reoccuring electrical problem . It's intermitten and seems to only happen under hard acceleration.When I nail it the radio will shut off the amp gauge pegs out and the lights get really bright plus the lights in the speedometer and tach go out but readings are not affected. i've had it to the dealer but they said they caint get it to happen while they have it in their shop. anyone experienced anything like this.
     
  2. gs34

    gs34 Junior Member

    639
    28
    5
    Sounds like you've maybe got a short to ground on the + side of the circuit that feeds the radio and instrument lights. You're going to have to get your manual out and see what all is fed in that circut.
    If it only happens under hard acceleration, I would look for a point that possibly takes a sstrain by the acceleration and might move a little. Possibly it is forcing a pinch of the wiring into a metal surface.
    You're probably going to have to look long and hard to find it.
     
  3. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    43
    I would have the voltage regulator tested,it sound like when you twist it hard the voltage regulator is allowing all the volts from the alternator through,leaving only the battery to try and control it harming the battery and ultimately everything else electronic.
     
  4. gs34

    gs34 Junior Member

    639
    28
    5
    You're going to have to explain that one to me Steve. I'm not following you at all?? :33:
     
  5. krikket

    krikket Active Member

    327
    26
    0
    In other words, the voltage regulator isn't limiting enough voltage (lights get really bright and radio cuts out due to over-voltage). The battery is not only storage for dc voltage, but it also acts as a shock absorber to amperage and voltage spikes, but it can only handle so much.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    I would be inclined to thing a problem with the stator.
     
  7. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    43
    Thanks for replying krikket,I didn't see gs34's post
     
  8. gs34

    gs34 Junior Member

    639
    28
    5
    OK guys. I follow your train of thought now. You could very well be on the right track. I just couldn't get a handle on what you were thinking.
    Thanks. :D :D
     
  9. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    43
    thing???????????:D Sorry Glider I still owe you for charp
     
  10. krikket

    krikket Active Member

    327
    26
    0
    Didn't mean to steal your thunder, bro!!::27: