08 High idle problems

Discussion in 'Touring Models' started by whatyardwork, Jun 15, 2008.

  1. whatyardwork

    whatyardwork Banned

    829
    0
    4
    Dropped off my FLHX Friday for its 1000 mile service and was informed by the dealer that Harley has come up with a new download to correct the problem.As my bike has yet to expierience this problem I cant tell you if it worked.Anyone having this issue might want to swing by your dealer and look into this.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. MWGB

    MWGB Member

    55
    16
    0
    My 2008 RKC goes in for 1K service next week.

    I'll let everyone know if it cures the problem, cuz I GOT IT.
     
  4. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    I look forward to seeing what they do
     
  5. MWGB

    MWGB Member

    55
    16
    0
    UHHH, I may let someone else go first, after reading Glider's snippet from HDNet.

    "Under certain conditions and riding styles some customers may notice a slightly different throttle feel, or comment on reduced engine responsiveness. This is due to the increased dead-band and will feel similar to a loose throttle cable adjustment on non-ETC (electronic throttle control) vehicles."

    I'm not so sure that the cure is not worse than the illness. I don't want to lose any throttle responsiveness. Heck, that's the best part!
     
  6. Ozoneman

    Ozoneman Active Member

    322
    26
    0
    With all these problems with the 2008s I'm glad I bought a used 2006!
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    I really think this new throttle system is going to bite them in the butt until they iron things out. It will end up costing them a bit of money to the dealers for downloads and other things too, but that's OK, they have it!:D
     
  8. MWGB

    MWGB Member

    55
    16
    0
    Just to follow up, I took my 08 RKC in for 1000 mile service and made sure that the high idle problem was added to the work order. I mentioned that HD had a new download to fix the problem (known to me because of HDtalking), but the service advisor gave me the look of " what are you talking about?" They held it for 2 extra days as they waited for a new "speed sensor".
    Since I've had it back and put about 600 more miles on it, the high idle is as bad as ever. Every 3-5 starts, I'll have to go through the on-off 4 times routine.
    I'll take it back soon. I printed a snipped copy of Glider's post regarding the HD Tech Bulletin that describes a new download to fix the problem, but after I re-read it, it mentions that a tuner cal over the update will wipe out the bug fix. I'm not sure that I got a true "tuner cal" with my Stage 1 upgrade so I don't whether or not the new flash will wipe the stage 1 flash or not.

    I'd rather deal with the high idle than too lean a mixture.

    Any advice?
     
    Last edited by a moderator: Jul 10, 2008
  9. glider

    glider Veteran Member

    25,464
    108
    44
    It's typical for the dealers to give you that reaction when you bring something in that THEY are supposed to know. I've had the same experience with a few myself.
    I would return to the dealer with the info in hand and let them sort it out. From what my take is about the download/fix is that it is supposed to allow time for the ECM to "adjust" to a normal throttle setting for 10 seconds after shut down to eliminate this problem. Let the dealer/MOCO figure out the fix and do it for you to make it right.