08 FXDB not starting

Discussion in 'Electrical' started by billwi, Feb 28, 2010.

  1. billwi

    billwi Member

    18
    11
    0
    My 08 FXDB will do nothing when the start switch is pressed. All fuses are good, plenty of juice in the battery. Now comes the curious part: the security system idiot light comes on and stays on. I do not have the security system on my bike! Also, with the ignition on, the turn signals do not activate. I had the bike started last weekend and everything was fine. Is there something that I am overlooking? Please help! Thanks!

    Bill
     
  2. Phantomrider

    Phantomrider Member

    12
    11
    0
    I had similar problem with my 08 bob. Running fine one day and then the next ... nothing. Turned out to be faulty wire in ignition switch.
     
  3. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Welcome to the forum bill, first thing are there any trouble codes?
    I'm sure you checked the run switch, I would check where the relay wire plugs into the starter I've seen bad contacts there before, I would also check the clutch switch, that would disable the starter, the turn signals not working is weird and probably a sign.
    Do you have a service manual?
     
  4. billwi

    billwi Member

    18
    11
    0
    Yes, I do have a service manual. By using it and some advice from a service writer at the only dealership in my area that was open on Sunday, we narrowed it down to the TSM, or turn signal module. This is wired into the security system and the signals not working in conjunction with the security light on tipped him off. Have a bid out on eBay for a new module. Gotta save money where I can!

    Thanks for the reply, guys. I'm glad I found this site. Seems to be a very valuable resource!!!!
     
  5. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Too bad the warranty is up, don't forget password learning when you install it, it's in your manual, also a tssm would fit right in the hole if you ever thought about the upgrade, now would be the time, or if you have a friend that did the upgrade he might make you a very good deal on his take off tsm.
     
  6. billwi

    billwi Member

    18
    11
    0
    Well, unfortunately, it was not the TSM. Bike is now on it's way to the local dealership. I do have extended warranty, so it will only be $50. For those trying to keep up and may have the same issue, I will post the resolution when I find out.
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Dont 08 have 2 year warranty depending on when purchased
     
  8. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Glad to hear you have ESP, $50.00 bucks is not a bad deal, let them do it all, looking foward to you posting what it was.
     
  9. billwi

    billwi Member

    18
    11
    0
    Well, I haven't seen the parts yet, but apparently the wiring harness rubbed through in several places and started frying electrical parts (starter relay, 1 of the coils, etc.). Parts are on order and I SHOULD have my bike back sometime late this coming week.

    BTW....ESP ROCKS!!!!! Will never buy another H-D without it!!!!!
     
  10. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Congrats :)