08 Cruise Control Not working

Discussion in 'Touring Models' started by daharleyrdr, Apr 7, 2008.

  1. daharleyrdr

    daharleyrdr New Member

    4
    11
    0
    I have a new 08 FLHTC dealer installed cruise control and it worked fine the one time I used it. Bike now has 480 miles on it and the cruise stopped working. When you turn on the dash mounted rocker switch it lights up but the icon on the gauge doesnt light up, hence it no workee!!! The only mod I did was plug in led rear fender tip light, brake light from "RideTimeTechnology, and the HD Brake Light Conversion Kit. I unplugged the LED but its still not working, fuse is ok. Again the dealer installed the Cruise after taking delivery of the bike in a "Swap" for another to get me the model and color, Dealer briefly looked at it also checked fuses, and tech checked for diagnostic codes, I dont thingk there were any I was looking over his shoulder hard to see. Dealer said Id have to leave the bike, can anyone help me on this? Thanks Bill :bigsmiley19:
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Last edited: Apr 7, 2008
  3. Vibratinharley

    Vibratinharley Junior Member

    428
    28
    1
    Are 2008 FLHTC's the same as my 08 Ultra with the drive by wire. Might be different without cable adjustment.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Woops, overlooked that, you are right.:D

    New fangled things! Thanks!

    Back to the dealer.
     
  5. daharleyrdr

    daharleyrdr New Member

    4
    11
    0
    Hey Guys
    Ill let you know the outcome, dropped the bike off at the Dealers last night!