08 1200c electrical issue

Discussion in 'Sportster Models' started by 67hat34c, Jan 16, 2009.

  1. 67hat34c

    67hat34c Active Member

    297
    26
    0
    08 1200c 7200 miles. Has 2 electrical problems that the dealer can fix at this time.

    First problem that showed was the Low fuel light comming on and off randomly way before it should. Full tank, ride about 20 miles and the light starts to turn on and off. Will do this all the way until it needs to stay on when it hits 120 to 135 miles then stays as it should. Dealer replaced the resistor on one visit but the problem showed up again. Next visit they drained the tank and watched the light come on when it should, ran it on dyny for a few min and never saw the problem show up. I asked them to disconnect the wire from the sender to isolate the spedo. ie, if light comes on then there is a problem in the speedo. Shop refused.

    Second problem was the battery going dead, with key out of the bike and the run switch off the fuel pump will run. They found fuse block corroded so they cleaned it and put in dielectric grease. Well problem came back next time i used the bike. Took it back and they could not get it to duplicate the symptom. They refused to do any exploritory. I think it is fuse block and or the run relay switch. Asked the shop to simply put in a new relay, no way.

    Still have 13mo of warranty so not too concerned but what a PITA.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Your low fuel light comes on as a resistance change from the sending unit changes. If it is lighting at the wrong time intermittently, the resistance isn't correct and I think the dealer is pulling your leg about changing a resister in the system to get rid of you. It sounds as if they are the typical "they all do that" variety. Generally when it doesn't come on the gauge gets replaced but if it is coming on sporadically, there could be some problem with the sending unit in the tank. It's basically a rheostat and sending the wrong value would light the lite when it shouldn't be lit.

    Check the wiring to the gauge to make sure there are no bare spots and you can use this test to see if the meter fluctuates smoothly when you change the amount of fuel in the tank by draining the tank with the meter attached and watching the needle on the meter. It should move smoothly from full to empty as the fuel drains. If it jumps or anything other than smooth, the sending unit needs replacement.

    Fuel Gauge and Sender Test - Harley Davidson Community
     
  3. 67hat34c

    67hat34c Active Member

    297
    26
    0
    Bike is still at the dealer, I Emailed the Service manager this AM with the 2 issues at hand, thus far no response. I plan to go by after work and pick it up regardless of status of repairs. Want to ride on sunday.

    The system bleading power when key is off is more of a concern. If it dies in the garage I will call them and have them pu at my house and they can observe the condition.

    Light, well mabe is can rig a way for my digital camera to video the thing, dont know what good it would do but at lease i can show it to the service manage and prove to him that it is happening.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
  5. 67hat34c

    67hat34c Active Member

    297
    26
    0
    Didnt see it before but was aware of the issue. They did clean the block and install the dielectric grease but the problem came back a few days later. I did pull the battery cover and reviewed the block and it was cleaned and greased as they indicated. I wonder however if it was done properly or if the run relay is bad. Well time will tell.

    Email to service manager sent at 8am, now 335pm and no response. Well possible he does not read email that often, who knows. Did not set a cc when opened.
     
  6. 67hat34c

    67hat34c Active Member

    297
    26
    0
    OK, now I am going to vent a little.

    Yesterday someone called me from HD at 530pm to tell me bike was ready. They said the ran multi tests and even ran it on Dyno for a while and could not get low fuel light to act up not could they find a problem with battery draining. Well I picked it up tonight, went out and hit the trip meter and it had 4.7 miles on it, checked a and b an they are the same. Well I filled it up on the way to HD last sunday and 0 out both meters and yes it is 4.7 miles from the Hess station on Turkey lake road to Orlando Harley Davidson. Clearly they did not run on the Dyno and suspect the rest of their testing was questionable.
    I complained a little and made them at least replace the run relay switch which I suspect may be problem with bleeding power. Told them if the problem returns then I want a new fuse block. Told them I will watch the low fuel light and will take it back to them at a later date.

    You know all I ask is for people not to lie to me. Believe I have a posting on another part of this forum or another one about poor quality mechanical work that I have experienced in the last year. When the survey company calls about my service experience guess what I am going to say...