'07 Road King won't start

Discussion in 'Touring Models' started by gditt, Jul 3, 2010.

  1. gditt

    gditt Member

    7
    0
    0
    Need some guidance, turn switch on and everthing lights up like it suppose to but when I pust the start button nothing happens, battery? This lights come on and the security system makes the turn signals flash but the starter does not even try to engage. Original battery but I have had no sign it is going bad. Just noticed to that when I turn switch off the turn signal flash longer than they use to.
     
  2. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    battery in your keyfob bad ? can you enter the bypass code and have it start? sounds like the alarm is keeping it from starting
     
  3. jerrybombard

    jerrybombard Active Member

    115
    26
    0
    not to sound pretensious, or insult, but is the "run" switch on....as this just happened to me recently....pushed that 800 lb beast home 1K feet only to find that was MY problem.....:D
    Oh, and do you hear the fuel pump run???
     
  4. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    No worries Jer...engine kill switch should be used to kill engine first before turning off ignition on EFI equipped HD Twins so the ECM can save into memory all the sensor shutdown settings (including idle speed). Easy to forget if you don't shutdown with the kill switch out of habit.

    That and the Security silent alarm ignition disable portion not being diarmed on proximity based buttonless fobs. Coin battery is easily changed out and comes in pairs (though one would think if you carry both fobs 1 or the other being near bike should allow easy starting.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Check your TSSM trouble codes...


    TSM/TSSM Trouble Codes - Harley Davidson Community

    You may also have a clutch interlock switch problem or neutral switch problem.
     
  6. gditt

    gditt Member

    7
    0
    0
    Glider, I can't get past the step where you push the right turn signal the second time, when I do this the flashers go through a 10 cycle set and then everything seems to go back to the beginning. I have checked battery which was showing 12.54VDC and checked at the solenoid with the starter button pushed in am not getting any voltage. Replaced batteries in FOB's also. Is the duration of flashes after the second right turn signal push a signal of something? thanks for everyones advice
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Time to back up through the start circuit. Check the starter relay for in and out as well as operation when you press the start button. Also verify the start button circuit when you activate it with a meter that it is a good circuit and operating to energize the relay.

    Starter Relay Wiring - Harley Davidson Community
     
  8. gditt

    gditt Member

    7
    0
    0
    TSM/HFSM codes

    Has anyone run into this? Trying to run the fault codes on the TSM/HFSM system and when I get to step five where you press the right turn signal for the second time the turn signals flash fifteen sets of four and then the system turns off. Doing something wrong or is this some code? Bike won't start and running through some different diagnostics to try and figure out whats up. Is there a way to test module?
     
  9. gditt

    gditt Member

    7
    0
    0
    Update! I think I have narrowed it down to the TCM module. I can make the starter relay with battery voltage and started pulls in. One side goes through start switch on handlebar and other side comes from TSM/HFSM module. Is there anyway to troubleshoot this module? Is there anyway to bypass to see if that is it?
     
  10. zaniel

    zaniel New Member

    1
    0
    0
    hey i was wondering if the problem ever got solved i have a 98 roadking that is doing the exact same thing and i would appreaciate some insight.