07 Deluxe shutting off

Discussion in 'Softail Models' started by Skyrunner, Dec 31, 2011.

  1. Skyrunner

    Skyrunner Member

    46
    16
    0
    Wifes 07 Deluxe started shutting off today when coming to a stop. Starts right up when restarting. Checked for codes and none appeared. Plenty of gas in the tank. Planning on changing the plugs and was wondering if anyone has any other possible solutions. Happy New Year to all.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Happy New Year to you too. Try flushing the IAC. It may be sticking.
     
  3. Skyrunner

    Skyrunner Member

    46
    16
    0
    Thanks Hoople. I just checked the IAC and it does appear dirty. Going to the parts store tomorrow to get some carb cleaner to clean it.
     
  4. cheap80z28

    cheap80z28 Member

    82
    18
    1
    mine did that on occasion and dealer changed out a intake gasket? worked fine for a season and started up again at the end of the year
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  7. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Could also be something simple like picking up bad gas, so fueling system may have contaminants in it. Anything different in your (her) routine regarding fueling or recent service?:eam
     
  8. Skyrunner

    Skyrunner Member

    46
    16
    0
    Flushed the IAC, changed the plugs, topped the tank with fresh gas, and added some sea foam. Took scoot for a ride and it kept wanting to stall at first, but after 5 miles or so it returned to normal. Thanks again for assistance.
     
  9. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Doesn't sound like it's fixed.
    So once it is warmed up, it was OK? By chance do you have a Power Commander on the bike (or anything between the original Delphi ECM and the wiring harness).

    Other than the idle issue, the bike pulls good in a tall gear without any sign of surging?

    When the bike is cold you should see a higher idle than normal. It is part of the warm up enrichment firmware/software. Do you see that uplift in RPM when the bike is cold.

    Does the problem only happen when the engine is cold?
     
  10. Skyrunner

    Skyrunner Member

    46
    16
    0
    The only mod is Sampson BG3 pipes. Scoot does pull good in a tall gear without any sign of surging. Scoot does idle higher at start now (warm), but it didn't when it was stalling. When it was stalling it was not idling higher and that is what cought my attention, besides the stalling. Scoot seems to be her old self now. Going to fire her up this morning to ensure cold idle is higher (normal).