06 Street Glide Running rich P0505

Discussion in 'Touring Models' started by tnastear, Oct 24, 2011.

  1. tnastear

    tnastear New Member

    2
    0
    0
    Hello all. I just bought a 2006 Street glide that had 19500 miles on it when i got it it now has 22579. When purchased it had python mufflers and a K&N high flow air filter. I installed a fuel pak and everthing was great. I then put on 12 in bagger apes and changed out the clutch cable to make them fit (Was able to reroute throttle and brake) I just took it for a 1400 mile road trip and it is running way rich. Able to smell it crusing at 90. about 400 miles in i disconnected the fuel pak with no change. My buddy also has a 06 street glide and he could not ride behind me because of how rich the bike is running. We both got the same milage. 36-42 depending on how hard we rode. I just just checked for codes and have a P0505 Idle control fault. Idle control seems ok except on cold starts if i don't let it warm up a bit before giving it gas it will not idle for the first couple blocks (also started after bar install) I am at a loss. Could throttle cable adjustment cause this?
     
  2. SledDog

    SledDog Senior Member Staff Member Moderator

    1,852
    58
    42
    It's possible. If the throttle cable is not adjusted correctly it could be holding the throttle open not letting the IAC idle the bike down.
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Harley Davidson Community If the last thing you did to the bike was the handle bars I would suspect the cables for binding tho it would not hurt to clean the IAC
     
  4. btsom

    btsom Active Member

    341
    38
    6
    When I got a code for one cylinder being rich, I changed (replaced) spark plugs and the code has not returned. That is a relatively inexpensive experiment and and won't cause any other problems
     
  5. SeaRider04

    SeaRider04 Active Member

    372
    26
    0
    ....I then put on 12 in bagger apes and changed out the clutch cable to make them fit (Was able to reroute throttle and brake.....

    Your cable might be a tad short which might hold the throttle plate open just enough to set a code, P0505 in Automotive Industry is use to indicates the engine rpm is out of range, they may use the same standard "P" code on Motorcycle too. I'd check the throttle cable routing again and make sure the cable has enough slack in it. Just a though.
     
  6. tnastear

    tnastear New Member

    2
    0
    0
    I cleaned the throttle body (soaked with oil from breathers) took care of idle problem untill last night. time to clean again and replace breathers. Checked throttle cables no binding. I suspect rich problem might be caused by intake air temp sensor getting soaked by oil. Although after cleaning intake my milage has seemed to drop. I will verify on next refill. Also going to change plugs.
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Don't rule out a bad cylinder head temp sensor either. They are designed to richen the fuel at cold start and lean it out as it warms up. It may not be leaning it out after warmup.

    Take a look here. It's located on the rear of the front cylinder.

    Harley Davidson Community