05 Ultra - Directional Problem

Discussion in 'Electrical' started by sal537, Oct 17, 2011.

  1. sal537

    sal537 Member

    10
    0
    0
    got this bike used, everything been great till yesterday and left directional stopped on me. Front dir was on but indicator and back were out with a faint blinking in the front one. took back cover off to change bulb and its LED(no bulb to change) Could a loose wire on the indicator cause the back bulb to go out as I did add a amp and speakers recently?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    There's a number of things including a loose wire that can make the light go out but look under the fender for signs of the tire rubbing through the harness there. You have to test of power in the light socket and also for ground too.
     
  3. sal537

    sal537 Member

    10
    0
    0
    Thanks, but they are sealed led units, so no socket to test.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Do you have a connector plug in the wiring to the lights? You can back track to the plug under the seat for starters and go from there.
     
  5. sal537

    sal537 Member

    10
    0
    0
    try that thanks, also noticed when i put alarm on both dir indicators used to light now the left doesnt.
     
  6. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,316
    73
    130
    As Glider suggested the directional is tied into the harness at some point. Work your way to that point and do some checking with a test light or multimeter.
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Retrace your install of the amp for pinched wires first JMO:s
     
  8. sal537

    sal537 Member

    10
    0
    0
    Thanks, think I will start with checkin my amp install first tomorrow.
     
  9. sal537

    sal537 Member

    10
    0
    0
    found two trouble codes, b1121 and u1097. looked them up , what does loss of speedometer seriel data mean?
     
  10. sal537

    sal537 Member

    10
    0
    0
    dropped the ramp to my lift on my big toe (broken) to add to my frustration